Putty serial setup with Debian Jessie

Hello all;

I have just installed Debian Jessie (8) on an x86 machine.

When I went to setup Putty as I did on my Windows Xp machine there was no way to

Set flow control to “none” my only options were XON/XOFF and CTS/RTS.

Does anyone know what is wrong here ?

Bill

“No one could make a greater mistake than he who did nothing because he could do only a little.”

“All that is necessary for the triumph of evil is that good men do nothing” Edmond Burke (1729 - 1797)

http://www.packtpub.com/building-a-home-security-system-with-beaglebone/book

http://ca.linkedin.com/pub/bill-pretty/2b/b07/602

Hello all;

I have just installed Debian Jessie (8) on an x86 machine.

When I went to setup Putty as I did on my Windows Xp machine there was no way to

Set flow control to “none” my only options were XON/XOFF and CTS/RTS.

Does anyone know what is wrong here ?

I am.

But I would prefer the integration of Putty, which also has SSH.

Or I would like to, hence my other post J

Is Linux Putty different than Windows Putty?

On Windows Putty, the controls you are asking for are in
Putty Configuration/Connection/Serial/Options controlling local serial lines/Flow Control.

— Graham

Yeah.

That’s the weird thing.

I get the same flow control dropdown list, but it just has XON/XOFF or CTS/RTS as options.

There is no “none” option. Maybe I should post a screen grab ?

That is a shame. Sounds like a Putty bug, not a Linux problem.
Select CTS/RTS, Connect the CTS wire to the RTS wire, and let her rip.
Same result as “selecting none.”

— Graham

Unfortunately it is an FTDI USB adapter L

If it is the six wire version for the BBB, FTDI TTL-232R.

CTS is pin 2 is BROWN wire, RTS is pin 6 is the GREEN wire.

— Graham

You’re right !!

It’s a sparkfun board, but I can do the same thing.

Never thought of that.

Thanks J