python-pyserial for BeagleBone A 5 with Angstrom Image 02/14/2012

Hi All,
I just got my BeagleBone A5 with the latest Angstrom image from 02/14/2012.
I am getting “Unknown Package” when trying to install python-pyserial.

Command: opkg install python-pyserial

The installed Python version seems to be 2.7.2.
I searched here and pyserial seems to exist (as version 2.4):

I did some google searches, but all the links use earlier versions of the Angstrom Image (e.g.

Any suggestions how to get pyserial installed? I don’t have much experience with opkg.

Thanks for any pointers,


I have had the same experience, I wonder if its been rolled up into another package. Will continue to search.

I followed the instructions here:

Try opkg install python-serial

2012/5/20 Hugh Johnson <>

Also " easy_install pyserial", assuming you have python_setuptools installed.


On my Beaglebone running the same image, I installed it with “opkg install python-pyserial”. It’s still in the package list under that name:

root@gigamegabone:# opkg list | grep “pyserial”
python-pyserial - 2.4-ml3 - python-pyserial version 2.4-ml3

However, I did have a similar experience with that package. I just tried installing on the 2012.05 image (i.e. opkg install python-pyserial), and it gave the “unknown package” error. The above grep command couldn’t find it either.

So, I installed python-modules (opkg install python-modules) to see if it was included in there. It wasn’t. But when I ran “opkg install python-pyserial” again, this time the package installed.

So, I don’t know if installing python-modules had anything to do with it, or it’s just that opkg install is somewhat unreliable. (Yes, I ran “opkg update” before doing all of this).

The approaches suggested by Hugh and David are good workarounds – most Python packages can be installed by those methods, and often you’ll get a more up-to-date version that way than by using opkg.


I am on an older version and I can assure you it is there. I am still on the 12/??/11 image I think.

I did give that a try, but had no success.

opkg list | grep pyserial

Yielded no results; that's why I was wondering if pyserial had been rolled up into another package recently.


Thanks for the response. I'll run through the steps you mentioned to see if I can mimic that behavior. Will post back with my findings.



Strangely enough, I rebooted, did opkg update, then opkg list | grep “pyserial” and there it was. I must have run that command half a dozen times last night with nothing returned.

Thanks for the suggestion.


The magic for me was to run ‘opkg update’ first. This was a brand new BBB.


For what it’s worth. I just reflashed my BBB with the production image 09/04/13 Angstrom. When trying to install pyserial I tried opkg install python-pyserial and it did not work, i also tried the pip and easy_install from the pyserial instructions page and i had already installed python-setuptools.

What ended up working was:

opkg install python-modules
opkg install python-pyserial

Just for anyone having the same difficulties:

I’m using the angstrom distribution on REV A5C, and I was following the adafruit BBIO installation for using UART. The specified “pip install pyserial” did not work for me.
I succeeded in installing pyserial using “opkg install python-pyserial”.