Qt embedded widget demo?

Hi all,

I would like to run some Qt Widget demos on my BB.

How can one compile the Qt demos for Angstrom?
Is there a howto section somewhere which may have step-by-step Qt installation instructions for Angstrom or BeagleBoard?

I tried to follow the qt embedded installation for my linux host.

Please have a look at my steps:
-downloaded qt-everywhere-opensource-src-4.6.2.tar.gz

  • extracted
  • cd qt-everywhere-opensource-src-4.6.2/
  • ./configure
  • ./configure -embedded arm -xplatform qws/linux-arm-g++

Which other options would fit for Angstrom applications?



I am looking forward to use a qt-gui oe image and develop qt embedded applications on my linux host using QT- Creator.
Well I’m OK now with the kernel and u-boot , I’ll start working on the qt-gui rootfs on monday, than I’ll face your prolems.
Did you get any further?

Hi Kunal,

I'm working on the same topic and I found the following config on the TI website :


./configure -prefix /opt/qt-embedded -embedded arm -platform /qws/linux-x86-g++ /qws/linux-omap3-g++ -depths 16,24 -no-cups -no-largefiles -no-accessibility -no-openssl -qt-mouse-pc -qt-mouse-linuxinput -plugin-mouse-linuxtp -plugin-mouse-pc -fast

sincerely I don't understand all of it but I think I might also intersted in adding at least -qvfb ...

Did you get any further?


Kunal ha scritto:

Thanks Fabio.

I recently involve into different development. However, sooner i am going to hope on this one.

Your information will be helpful for that. Thanks again.


If you want to compile QT yourself, you should use openembedded. If you just want to compile QT apps, you can use the angstrom qt sdk: http://www.angstrom-distribution.org/toolchains/



Following this hints

I didn’t make use the -qvfb switch, but magically it works…

I have the QT embedded framebuffer sample running, I compiled it using

  • QT Creator, only need to add a couple of PATH entries
  • OE generated toolchain (the same that builds my custom kernel and the console-root-fs)
  • QTEmbedded 4.6 I got from the git repository, stable/4.6 branch, adapting the mkspec for this toolchain.

I had some issues while making QTEmbedded but I solved it brutally casting a void* to the required type in the source code
Now I have additional issues running OpenGL…

On the other hand, I’d love to use the SDK, but I’m missing some basics, all I found is http://docs.openembedded.org/usermanual/html/ch05s08.html and building QT is unfortunately far beyond my needs and skills. Thanks anyhow I’ll try to follow the link.