QT for Beagleboard xM

Hi, i have Ubuntu Natty host PC and BB xM running Ubuntu Natty also. I have tried to install QT on my host machine to develop applications for my BB. I have followed steps explained in http://treyweaver.blogspot.com/2010/10/setting-up-qt-development-environment.html and http://processors.wiki.ti.com/index.php/Building_Qt. But it continues to give me errors such as no tool chain can produce code…, or libc.so not found and so on.

1- Which toolchain i must use?
2- Which file i must copy to BB?
3- Is it so hard to develop application for BB running Ubuntu?

Hi,

1.Follow the Treyweaver blog and use the required toolchain mentioned
in the below link

    http://www.angstrom-distribution.org/toolchains/

2.After configuring qt in your host system the output files wil be
present in /opt/qt-arm directory. So copy all the files in /opt/qt-arm
directory to the beagleboard

Regards,
Jyothi
TenetTechnetronics

http://tenettech.com/
http://tenettech.com/blogspot/

thanx, it works

2011/9/8 Jyothi <jyothik41rao@gmail.com>

I'd recommend using narcissus to create your Angstrom image.
Use it's toolchain. And make narcissus install QT on angstrom.

For make this, must I use Angstrom on host and target?

2011/9/9 ZubairLK <zubair.lutfullah@gmail.com>

Just on target

hm, on the target now ubuntu is running, i could build and run my first application on target by following steps on http://treyweaver.blogspot.com/2010/10/setting-up-qt-development-env and copying all folder on target machine. also copying my first application. but where i run the app with “./myFirst -qws” it is opening, but after then, the app does not work. when i scroll the mouse on the app, it freezes and begins to shows the screen that is under the app on the screen. what can be the problem???

2011/9/9 beagleguy <x533p@unb.ca>

it is interesting how fast a "hello world" QT application can be built
on such slow CPU.

Hi,
I get the feeling you are running an X-windows like system, am I correct?
You are using the –qws option, this is for using Qt direct to the framebuffer without X-windows or a window manager.
Using –qws when you are using X-windows will give the overwriting corrupt screen behaviour you have described.
As well as leaving the –qws option from your command line, you would have to reconfigure Qt to not use QWS.
BR,
Ian.

Hi, the problem seems is not only for my first program. It also occurs on QT demos applications. When i try “without -qws” it gives me error “QWSSocket::ConnectToLocalFile could not connect::Connection refused”. The application appears on screen using -qws, but when i try to click or press on any key, the display breaks down, it begins to show parts of the previous screen. How can i reconfigure QT not to use qws?

2011/9/9 Ian Guffick <iguffick@iee.org>

Just a quick note for the one running Ubuntu on target:

  • Install libqt4-core, libqt4-dev, libqt4-gui and qt4-dev-tools by using synaptic package manager on BB-xM
  • qmake → generates Makefile automatically
  • Qt Designer → GUI layout and design
  • Qt Creator → a cross-platform IDE

As an example if you have a main.cpp the following command lines build the executable on BB-xM

  • qmake -project
    // creates project file
  • qmake
    // creates Makefile
  • make
    // compile and build main.cpp
  • run the executable generated in the folder.

Regards,
Ozkan.