QT5 on BB black Ubuntu+lxde: cannot exute binary file

I want to install the qt5-software on my BBB. My system is Ubuntu Precise with lxde.
I downloaded the 32-bit-software for linux here: download.qt-project.org/official_releases/qt/5.1/5.1.0/qt-linux-opensource-5.1.0-x86-offline.run .
I used these commands to install:

sudo su
apt-get install build-essential
apt-get install libx11-xcb-dev libglu1-mesa-dev libxrender-dev
cd Downloads
chmod u+x *


Output: cannot excute binary file.

I also tried the 64-bit-version, but it’s the same error :(.
What do i wrong?

You’re running this on the BBB? If so, x86 and x64 will not work. You will need something that is meant to run on ARM.


thats how to compile it for a PI i am sure with that help guide you can
compile it for the BBB

good luck


ok. I have a question about editing one command on this site: http://qt-project.org/wiki/RaspberryPi_Beginners_guide
I am at the step “Compiling qtbase”. The 2nd command must be edited, right?

2nd command on Website:

paulo@westeros:~$ sudo ./fixQualifiedLibraryPaths **/mnt/rasp-pi-rootfs/** ~/opt/gcc-4.7-linaro-rpi-gnueabihf/bin/arm-linux-gnueabihf-gcc

what must i write at “/mnt/rasp-pi-rootfs/”?

I would recommend that you watch this video, and understand what is going on.


I would not stick to Rpi. There is tons of instructions on the web how to compile Qt. If you work with omap3 then you better use links provided for Beagleboard and not Rpi. You will spend a lot of time struggling with Rpi related instructions and eventually will figure out that all this stuff is useless for Beagleboard

now use this guide: http://qt-project.org/wiki/Building-Qt-5-from-Git.

But at the end of the command “make -j 4” i got these errors:

In the qt-forum they say, that i should use the stabel build from qt5.1.0.

So i used the older src. And now i get these errors:



Nobody an idea?


pls help me!!