Qt5 on Debian BBB

I’ve been following this guide. However, I am attempting to use Qt 5.3 instead of 4.8.6 as in the guide. I’m using this Qt source for 5.3.1.

The differences start at the mkdir mkspecs/qws/linux-am335x-g++ line of the guide. In the Qt 5.3 source, there is already a directory: qt-everywhere-opensource-src-5.3.1/qtbase/mkspecs/devices/linux-beagleboard-g++ which already has a premade qmake.conf file (the guide explains that this directory and file don’t exist in Qt 4.8).

I would like to use the touchscreen and therefore I followed the guide’s instructions for building tslib. It says to add these two lines to the qmake file to enable the touchscreen support:

QMAKE_INCDIR += /home//qt-bbb/downloads/tslib/src
QMAKE_LIBDIR += /home//qt-bbb/tslib/lib

( in my case is just “seth”)

The premade file does not include these lines. It’s easy enough to add, but one of my questions is: Do I need to still do this for Qt 5.3 or is that somehow included already? I’d rather ask for help here first than to do it wrong and have to re-do it (I remember this process causing me headaches when I had to do it before on the BBW). I did try running the configure command with the -qt-mouse-tslib switch, but it complained that it wasn’t a valid switch so I would guess I no longer need to do this?

My last question (for now) is regarding the configure command. I’ve tried the following:

./configure -v -opensource -confirm-license -no-pch -no-opengl -make libs -device linux-beagleboard-g++ -xplatform linux-arm-gnueabihf-g++ -no-accessibility -qt-zlib -qt-libpng -qt-libjpeg -device-option CROSS_COMPILE=/home/seth/qt-bbb/gcc-linaro-arm-linux-gnueabihf-4.8-2014.04_linux/bin/arm-linux-gnueabihf- -prefix /opt/qt5

As this is similar to this post. However, upon running I get:

The specified system/compiler is not supported:

Sometimes the error gives enough info for me to figure out myself but I don’t know about this one. I never gave it /home/seth/qt-bbb/qt-everywhere… in the configure line so I don’t know where that is coming from. In fact, I thought the CROSS_COMPILE option I gave it would be the one used, but apparently not?

Note: I am using Ubuntu 14.04 for doing this. I got the toolchain from here where **gcc-linaro-arm-linux-gnueabihf-**4.8 is the latest.

If you think I could get more help by posting these questions on the qt-project.org forums I will do so. Thanks for any guidance!


I may have figured it out. I simply changed
-xplatform linux-arm-gnueabihf-g++
-xplatform devices/linux-beagleboard-g++
and it got past the error I was having.

I’ll post again here if I run into any more issues.

Or if you get tired of dealing with having to roll your own for most things just install ALARM(arch linux arm) and be done with it. All your QT{4,5} desires are there ready and waiting.

Thanks don. That’s cool Qt is all ready to go on ALARM. Is there also an easy way to change the splash screen to something custom, like what Plymouth seems to offer? I didn’t get there yet but it seemed like Debian had a few guides around that I could use.

would still be relevant except how you build packages on alarm vs debian. There site has pages in regards to that. Plus you end up getting the amazing wiki that is arch linux and you also get the best package manager around pacman. png to ppm put in the kernel src in appropriate dir edit kconfig logo.c makefile recompile install reboot, enjoy your new splash. Enjoy never reinstalling a new “release version” again and many more wondrous things and having to hack things back to how you want them or endlessly compiling cause X is out of date which ends up causing issues with Y and all the joys that is debian. I have alarm installs going on 4+ years, and arch linux installs on boxes much older.

Well that sounds really nice! Thanks for your help don - I’ll give that splash update process a shot.