Question about OMAP 2.6 Kernel Build for Beagle Board

nautronixlogo.jpg

Hello,
I am new to linux developments and I am trying to build the kernel. I have managed to build the xloader and u boot so I know the paths to gcc are all set up.

I am following the instructions here.

http://elinux.org/BeagleBoard#Source which asks you to do the following:

git clone git://git.kernel.org/pub/scm/linux/kernel/git/tmlind/linux-omap-2.6.git linux-omap-2.6
cd linux-omap-2.6

The git works fine and I have a local copy.

make distclean
make omap3_beagle_defconfig
make menuconfig # only needed if you want to change the default configuration
make uImage

When I invoke make omap3_beagle_defconfig I get the error

make omap3_beagle_defconfig

Can’t find default configuration “arch/x86/configs/omap3_beagle_defconfig”!

So I tried pointing to the correct architecture by setting

make ARM=arm omap3_beagle_defconfig

This still didn’t work. Then I tried specifying directly what toolchain to crosscompile with by.

make ARM=arm CROSS_COMPILE=arm-none-linux-gnueabi- omap3_beagle_defconfig

Still the same problem. Is there somewhere in the makefile that is not checking for arm to point it to the proper configuration at /arch/arm/configs/omap3_beagle_defconfig ?

I lifted the makefile unchanged so I have no idea what I have or haven’t done to cause this. does anyone have any suggestions ?

Regards
Paul McManus
Nautronix
Aberdeen,UK.

Paul McManus
Senior Software Engineer
Tel: +44 (0) 1224 775700
Fax: +44 (0) 1224 775800
Email: Paul.McManus@nautronix.co.uk
Website: www.nautronix.com

316055f.jpg

nautronixfooter.jpg

This email is sent and received in accordance with the terms and conditions as defined on our website. To view click here
Nautronix is a public limited company registered in Scotland. Registered number: SC062293. Registered office: Nautronix House, Howe Moss Avenue, Kirkhill, Dyce, Aberdeen, AB21 0GP

ARCH=arm

Paul McManus wrote:

Hello Pawel,
             I tried this before, both in the make statement and before it. It doesn;t make a difference. That is why I am wondering if there is an additional step not mentioned on the website which is obvoius to someone familiar with linux.

Thanks
Paul

are you doing this with an OE checkout? or with a kernel tree
checkout?

rday

...

  i just did that git clone, and ran

  $ make ARCH=arm omap3_beagle_defconfig

and it worked fine.

rday

Hi Robert,
  Thanks for checking I messed up the configuration file while
tinkering with it. I took everything out of the GIT repository and ran
it again and it worked fine as you said.

Thanks to you and Pawel for your replies.
Regards
Paul

On Behalf Of Robert P. J. Day