Questions about latest images.

I have two older A5A boards that I’m trying to use the August/Sept standalone SD images with. Both behave much different than the older image (not sure which one maybe june/july) I’m using from my recently fried Rev C board. I was able to take the backup image from that board and write it to an SD that I inserted in an A5A board and it’s mostly working. USB gadget shows up on my Macs and power button works as it should. I’ve been able to at least keep working on my project for now.

However, the new images I downloaded bott up and run on the A5A’s but they do not appear as a network connection when on USB and the power button does nothing when pressed. I have to access them by USB serial. Both show the usb0 device config in /etc/network/interfaces but neither show that present when I run ifconfig.

Is A5A supported on these images? I’ll be ordering a couple new Rev C boards later on but for now I have to continue on the A5A’s and I don’t see why that old image behaves perfectly while these do not. Without access to the USB ethernet if I lose my wireless while the board is in my robot it means dissasembly to get to it because the custom cape blocks the serial console pins.

I’m using an A5A with a semi most recent image. Well technically I built my own kernel, and used an alternate rootfs, but it’s basically the same thing minus a lot of “bloat”

Ok I’ve tried every image back to 08-05 and not one will:

  • Connect the USB network
  • Power off unless I force it down
  • Mount the SD image

All of these things happen correctly on the backup image which I guess I better hold onto like a diamond. I’m going to give the 05-14 version a try, then unless there is some suggestion on something to try aside from hand crafting my kernel, I guess I give up. I’ve spent several nights now dd’ing various images to SD cards and trying them with no success.

I’ve tried every image now down to 08-05 and none seem to be fully functional. Each image has had these same issues:

  • Power button does nothing, have to press and hold for 8 secs to force shutdown.
  • No USB network device appears at the host.
  • No SD partition is mounted from the device.

Minus any other suggestions or ideas beyond a hand-crafted kernel I’m guessing I’m going to give up. I’ll have to live off the backup image I have that seems to work correctly. I’m giving it one final try with the 05-14 version to see if that works. I’ve burned sever nights now dd’ing images to SD cards.

Dont know what to tell you other than everything you mentioned works fine for me. With a devboard of this type, some learning / prior knowledge is implied. Meaning, my suggestion is that you learn how to use the hardware, and the OS you’re trying to use.

I’ve spent the last year and a half learning, and still have lots more to learn. Welcome to the never ending source of learning some like to call embedded Linux.

Yes, I’m aware of the learning curve. I’ve been working with them since they came out. I also don’t know what to report other than every image after the 05-14 image booting from SD is not operating the expected on either A5A board. When I went back to 05-14 the devices show up, and the power button works. I fully ready to simply burn an image based on 05-14 and archive it for my needs but I’m curious if there is anything that I can provide might help track down the why. If not… I’ll move on.