rc_battery_monitor.service had to be manually enabled

Hello all,

I found that the battery monitor service (which controls the battery status LEDs) was not running on boot with the latest IoT distribution installation (bone-debian-9.2-iot-armhf-2017-10-10-4gb). For some reason, the service was disabled by default.

debian@beaglebone:~$ systemctl status rc_battery_monitor ● rc_battery_monitor.service - rc_battery_monitor Loaded: loaded (/lib/systemd/system/rc_battery_monitor.service; disabled; vendor Active: inactive (dead)

If this happened to you as well, simply enable it and reboot to get the battery status LEDs working on boot-up.

`
debian@beaglebone:~$ sudo systemctl enable rc_battery_monitor
Created symlink /etc/systemd/system/multi-user.target.wants/rc_battery_monitor.service → /lib/systemd/system/rc_battery_monitor.service.
debian@beaglebone:~$ sudo reboot

`

Hope this helps,
Robert

Thanks Robert - one mistery solved :wink: