RE: [beagleboard] Trying to get wireless (WL1271) driver working on Beaglebone

We’ve built a cape board containing a TiWi-R2 transceiver chip from LS Research. This chip has a WL1271 chip under the hood. We are using this cape board on a Beaglebone Rev A3. We are using the Angstrom distribution.

I’m trying to get WLAN working on this system. The host processor talks to the WL1271 chip over an SDIO interface. This is what I’ve done so far:

  1. I’ve configured the pin mux for the appropriate pins by writing to the appropriate “magic” files, for example:
    echo 0x36 > /sys/kernel/debug/omap_mux/gpmc_wait

  2. I’ve recompiled the Angstrom kernel, and I’ve loaded the kernel module wl12xx_sdio.ko, along with the following modules on which wl12xx_sdio.ko depends: wl12xx.ko, mac80211.ko, cfg80211.ko, rfkill.ko.

Have I loaded the correct kernel modules to support WLAN? Am I missing some module? When I load these kernel modules (using modprobe) I don’t see any WLAN-related messages in the dmesg output.

I thought I would have to specify parameters to the wl12xx_sdio driver telling it which WLAN IRQ to use and which SDIO interface to use (SDIO0, SDIO1, etc), but none of these modules support such parameters.

I have the feeling I’m missing something. I’ve been doing google searches and searching the beagleboard. I’ve found this topic:

This topic leads me to believe that I have to add support for the WL1271 chip to the kernel file arch/arm/mach-omap2/board-omap3beagle.c. Am I right?

Any help on what I’m doing wrong, or what I should be doing, would be greatly appreciated.

Hi Tim,

It’s been a while since I worked on getting WL1271 working on the Beagle-xM, but from what I recall, if you are able to get the wl12xx_sdio kernel module loaded, then the problem is probably with wpa_supplicant. I recall that dbus did not launch wpa_supplicant correctly so I killed off the dbus (wpa_supplicant) process that started wpa_supplicant manually. If you do this correctly, you will find a wlan0 network interface and you should be up and running. Make sure you have a wifi.config file setup for connman with your wpa_supplicant settings. You might have to restart connman with systemctl restart connman.service.



Tim M

– To join:
To unsubscribe from this group, send email to:
Frequently asked questions: