Recommend a Wireless USB adapter

I am using Angstom on a Beagleboard-xM.

I am looking for a recommendation on a good Wireless USB adapter. Need g,n and all of the security protocols; including WEP, WPA2, TKIP, AES.

Anyone know if the Linksys AE3000 works well?


realtek chips have the source code available for compiling on their website and if you are up to building your own kernel drivers…however the USB aspect of it has given me the most problems. I run a Belkin n150 and it is almost guaranteed that it won’t work if I try running it with the USB pc link. Running a SSH over eth0 has been a work around. I can recommend a lot of good links etc

I've tried a half-dozen different wireless USB adapters on the
Beaglebone with both Angstrom and Ubuntu, including a couple different
Belkin and Netgear models and an ultra-cheap Tenda. Have not tried
any Linksys products.

This Medialink adapter was the only one that worked consistently on
both platforms out of the box. Uses a Realtek chipset, and reasonably
priced at $19.

I used D-LINK DWA-131, a very tiny device. It works well on Ubuntu 12.04.

id highly recommend the following. they are 802.11abgn with an
atheros chipset. (atheros being one of the best chipsets out for
wireless and probably the most configurable as well as one of the few
companies fully and actively supporting open source drivers across
their product line)

netgear WNDA3100v1
D-LINK DWA-160 rev. A1/A2

pay specific attention to the version number as all these companies
have a nasty habit of continuing to sell units of the same model
number that look exactly the same outside but contain a completely
different chipset on the inside thus requiring different drivers.


This one has a tutorial and is sold specifically for beaglebone:

Hi Michael,

I bought one of these Medialink adapters from Amazon and have been having difficulty getting it to work on my Beaglebone and Beagleboard. I’ve tried all the tutorials, messing with the files in /etc/, yadda, yadda, but not luck. I would be very grateful if you could provide a quick how-to on getting this thing running on the Beagles.


I use the Alfa AWUS036h and AWUS036NH. Both I of them I have used on the BBXM with not a single issue nor have I had to do anything to get them working. The only thing I had to do was patch for injection. If you do not need that ability then there is nothing to do to use it other than connect it to the board and wifi. I have even hooked up 4 AWUS036h adapters the the BBXM with a powered hub and still had no issues.

I have luck with that chip and the rtl8187, that is my favorite. I use mine in drones. I just pulled off the housing. But yes alfas are not the smallest out there. If you find anything with either chip you should be in luck.

Side note that made me stick with alfas for those chips, was I say many threads stating the performance of the alfa vs a no name with the same chip did not offer the same performance results.

Good luck

Follow-up: I finally got WiFi to work, using the old 80211.g adapter from Belkin that I saw recommended in some other forums. It worked right out of the box (i.e. was detected when I did ifconfig wlan0). The reason is of course that the driver is in /lib/firmware (factory-installed, or I may have grabbed it via opkg update). Obviously 802.11g is less than ideal, but this is at least a start.

I recommend Asus USB N10 Wireless-150. Works out of the box for Ubuntu 12.04.2 with kernel 3.8.13-bone20.
Although lsusb says it’s RTL8192SU, it seems like it’s running on r8712u which is already included in the kernel.