Rev C4 Networking using USB ethernet

I have connected my Beagleboard Rev C4 to an USB Hub with ethernet
port to support networking from the board. After booting, I don't have
network capability.

The 'netcfg' command gives me the following results:

# netcfg
lo UP 127.0.0.1 255.0.0.0 0x00000049
eth0 UP 0.0.0.0 0.0.0.0 0x00001003

Looks like I don't have the my router gateway IP assigned to the
device 'eth0' as shown by the command below.

# cat /proc/net/route
Iface Destination Gateway Flags RefCnt Use
Metric Mask MTU Window IRTT

I tried to assign the gateway IP address with the following command,
but getting an error message.

# route add default gw 192.168.2.1 dev eth0
error: SIOCADDRT (Network is unreachable)

Any ideas? Thanks.

Try this:

# sudo ifconfig eth0 <ip address>

# sudo route add default gw <gw ip address>

I don't seem to have sudo command on my board. I tried both these
commands without sudo. It took them, but still unable to ping any
site. I get the following error message for 'ping' by IP address of
any server.

connect: Network is unreachable