RevC Web Browser when booting from SDcard 5/14/14 image

I downloaded the latest boot from SD card image(5-14-14 ) image and it boots fine.
I can Putty and WinSCP to it also.
The issue I am having is when I run the included web browser it will either open and
crash right away or will open an allow a couple of clicks and then it is gone.
I am not sure if it is crashing or hiding but if you keep trying to re-run it after a couple of
times it does not even open.
Also when I logged out after doing this it shutdown fine but when I tried to reboot the image
on the SD card was corrupt indicating missing modules

I re-imaged the SD card and it again boots fine and has same Web Browser issue

The Web Browser is Chromium on this image.

When I boot the flash emmc image that is on the board I do not see this issue with the Chromium
Web Browser I was able to get Cloud9 running.

I am booting with a mouse, keyboard and external monitor and networked to my home router.

Does anyone else see this issue

Thank’s
Tom