roboticscape library on the Blue - Motors reversed on rc_balance

I’m starting to play with the roboticscape library that comes on the Blue. I’m currently running “BeagleBoard.org Debian Image 2017-04-23”.

The rc_test_ routines seem to work well. However, when I run rc_balance, the wheels appear to spin in the opposite direction than what they should.

I’ve wired the red leads to the + terminals on the motors.

Does anyone know how to fix this?

–Mark

Swapping your motor leads might be the easiest. However, if you are not using the BeagleMIP kit, you will probably have to do some more tuning, so recompiling your own program would be necessary. The header file spells out many of the options you can tweak including reversing motors and encoders. It also helps if you have a degree in control systems.

Swapping the leads did it! It’s now balancing.

Wow, that was right out of the box!

–Mark

Swapping the leads did it! It’s now balancing.

Wow, that was right out of the box!

There are some definitions of the motor ports and directions if you end up wiring it different. Requires a recompile.