Rotating XServer to portrait on Beaglebone Black with no display manager

Hi,

I’m new to Beagleboards and haven’t done any kernel customizations but instead am using the provided Angstrom distribution provided with the BBBlack. (Or rather I believe it to be, the version is “Linux beaglebone 3.8.13 #1 SMP Tue Jun 18 02:11:09 EDT 2013 armv7l GNU/Linux”

I’ve gotten to the point where I have no display manager, but I need to run the X server because the graphical toolkit I’m using it FLTK, which does not support direct to framebuffer.

I’d like to have it go to portrait mode, for instance, writing to the fbcon/rotate file I can change orientation for the framebuffer, but once I run X it goes back to landscape.

I’m using the 4D Systems 4.3" LCD without the touch option: http://www.4dsystems.com.au/new/productpages/4DCAPE-43/downloads/4DCAPE-43%28T%29_datasheet_R_1_5.pdf

Here is my xorg.conf file and what I’ve tried:

`
Section “Module”
Load “extmod”
Load “dbe”
Load “glx”
Load “freetype”
Load “type1”
Load “record”
Load “dri”
EndSection

Section “Monitor”
Identifier “Builtin Default Monitor”
EndSection

Section “Device”
Identifier “Builtin Default fbdev Device 0”
Driver “modesetting”
EndSection

Section “Screen”
Identifier “Builtin Default fbdev Screen 0”
Device “Builtin Default fbdev Device 0”
Monitor “Builtin Default Monitor”
DefaultDepth 16
EndSection

Section “ServerLayout”
Identifier “Builtin Default Layout”
Screen “Builtin Default fbdev Screen 0”
EndSection

`

I’ve tried replaing “modesetting” with “fbdev” and to add “Option” “Rotate” “left”, or “CCW”, in any case here, it never loads and complains there there is no display.

Placing the option line in the Monitor section, another web hit I’ve seen, caused it to be complained about and ignored.

So I continue to google and try various combinations of adding this option, to no avail.

Some of the pages which have led me to trying these various options:
http://www.4dsystems.com.au/new/productpages/4DCAPE-43/downloads/4DCAPE-43%28T%29_datasheet_R_1_5.pdf
http://hipstercircuits.com/problems-with-beaglebone-black-and-their-solution/

The most common recommendation is to replace “modesetting” with “fbdev” and add a line saying: Option “Rotate” “CCW”.

The resulting log file. I notice it complains about most of the modules except for freetype and type1. Is there a way to resolve this by clearing up the fbdev complaint? Like installing fbdev? I’m just not familiar with doing that or what the package would be called.

`
X.Org X Server 1.11.2
Release Date: 2011-11-04
[1793357.452] X Protocol Version 11, Revision 0
[1793357.458] Build Operating System: Linux 3.9.0 x86_64
[1793357.463] Current Operating System: Linux beaglebone 3.8.13 #1 SMP Tue Jun 18 02:11:09 EDT 2013 armv7l
[1793357.475] Kernel command line: console=ttyO0,115200n8 quiet drm.debug=7 root=/dev/mmcblk0p2 ro rootfstype=ext4 rootwait
[1793357.486] Build Date: 20 May 2013 01:08:55PM
[1793357.492]
[1793357.498] Current version of pixman: 0.27.2
[1793357.503] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[1793357.514] Markers: (–) probed, () from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[1793357.530] (==) Log file: “/var/log/Xorg.0.log”, Time: Sat Jan 1 00:22:42 2000
[1793357.532] (==) Using config file: “/etc/X11/xorg.conf”
[1793357.534] (==) Using system config directory “/usr/share/X11/xorg.conf.d”
[1793357.537] (==) ServerLayout “Builtin Default Layout”
[1793357.537] (
) |–>Screen “Builtin Default fbdev Screen 0” (0)
[1793357.537] () | |–>Monitor “Builtin Default Monitor”
[1793357.538] (
) | |–>Device “Builtin Default fbdev Device 0”
[1793357.538] (==) Automatically adding devices
[1793357.538] (==) Automatically enabling devices
[1793357.538] (WW) The directory “/usr/share/fonts/X11/TTF/” does not exist.
[1793357.538] Entry deleted from font path.
[1793357.538] (WW) The directory “/usr/share/fonts/X11/OTF/” does not exist.
[1793357.538] Entry deleted from font path.
[1793357.538] (WW) The directory “/usr/share/fonts/X11/Type1/” does not exist.
[1793357.538] Entry deleted from font path.
[1793357.539] (==) FontPath set to:
/usr/share/fonts/X11/misc/,
/usr/share/fonts/X11/100dpi/,
/usr/share/fonts/X11/75dpi/
[1793357.539] (==) ModulePath set to “/usr/lib/xorg/modules”
[1793357.539] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[1793357.539] (II) Loader magic: 0x17b950
[1793357.539] (II) Module ABI versions:
[1793357.539] X.Org ANSI C Emulation: 0.4
[1793357.539] X.Org Video Driver: 11.0
[1793357.539] X.Org XInput driver : 13.0
[1793357.539] X.Org Server Extension : 6.0
[1793357.539] (II) “extmod” will be loaded. This was enabled by default and also specified in the config file.
[1793357.539] (II) “dbe” will be loaded. This was enabled by default and also specified in the config file.
[1793357.539] (II) LoadModule: “extmod”
[1793357.541] (WW) Warning, couldn’t open module extmod
[1793357.541] (II) UnloadModule: “extmod”
[1793357.541] (II) Unloading extmod
[1793357.541] (EE) Failed to load module “extmod” (module does not exist, 0)
[1793357.543] (II) LoadModule: “dbe”
[1793357.543] (WW) Warning, couldn’t open module dbe
[1793357.543] (II) UnloadModule: “dbe”
[1793357.544] (II) Unloading dbe
[1793357.544] (EE) Failed to load module “dbe” (module does not exist, 0)
[1793357.545] (II) LoadModule: “glx”
[1793357.546] (WW) Warning, couldn’t open module glx
[1793357.546] (II) UnloadModule: “glx”
[1793357.546] (II) Unloading glx
[1793357.546] (EE) Failed to load module “glx” (module does not exist, 0)
[1793357.548] (II) LoadModule: “record”
[1793357.549] (WW) Warning, couldn’t open module record
[1793357.549] (II) UnloadModule: “record”
[1793357.549] (II) Unloading record
[1793357.549] (EE) Failed to load module “record” (module does not exist, 0)
[1793357.550] (II) LoadModule: “dri”
[1793357.551] (WW) Warning, couldn’t open module dri
[1793357.551] (II) UnloadModule: “dri”
[1793357.551] (II) Unloading dri
[1793357.551] (EE) Failed to load module “dri” (module does not exist, 0)
[1793357.553] (II) LoadModule: “fbdev”
[1793357.553] (WW) Warning, couldn’t open module fbdev
[1793357.553] (II) UnloadModule: “fbdev”
[1793357.553] (II) Unloading fbdev
[1793357.554] (EE) Failed to load module “fbdev” (module does not exist, 0)
[1793357.555] (EE) No drivers available.
[1793357.557]
Fatal server error:
[1793357.560] no screens found
[1793357.562]
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[1793357.568] Please also check the log file at "/var/log/Xorg.0.log

`

Does the xrandr tool work ?

Something like:

xrandr -q

to query for the OUTPUTNAME, then

xrandr --output OUTPUTNAME --rotate left

regards,
Nuno

- --
http://aeminium.org/nuno/

Thanks for the responses, sorry I’m new to the google groups and was expecting email notification if there were any posts.

I solved this by installing fbdev.

opkg install xf86-video-fbdev

And my entire xorg.conf is:

`
Section “Device”
Identifier “Frame Buffer”
Driver “fbdev”
Option “Rotate” “CW”
EndSection

`

And depending on which way the hardware persons wants “up” to physically be, I use either “CCW” or “CW” to get the correct orientation.