Running headless but with X

I’m still trying to make this work in Angstrom. When I boot without a display, I can’t run X11vnc because there is no X running. If I boot with an LCD cape, I can run X11VNC but I only get a screen as big (or small) as the cape, about 480 pix wide.

I’d like to boot without a display, then remote in with VNC and get a nice GUI image.

Can someone suggest an approach to achieving this end by perhaps modifying some boot settings?


Does X tunneling over SSH work?

That is “ssh -X”

Try the info in this link. Should solve your issues

This link works for me: if you add the command there to your bashrc file it should work every time you login to ssh. There might be a better way but it works for me. If you don’t want to ssh in every time you could also put it in your systemd file.

Besides the other answers, I found a pretty good answer on this forum:!topic/beagleboard/61iD4INQ6xM
Thanks to those who replied. This did work for me, even after a reboot.