Running Labview

I currently use a windows based laptop to run labview developed software for an analytical instrument I am developing. The software is basically a curve fitting program that records data, flattens the baseline and calculates peak areas and height. I want to get rid of the laptop and simply put a processor in the instrument with a touch screen. Is this possible with Beaglebone?

Thanks,

Philippe Dekleva

You will have to determine what it takes to run Labview in a Linux environment. Then you have to see if BBB meets that requirement.

-david
.

I currently use a windows based laptop to run labview developed software for an analytical instrument I am developing. The software is basically a curve fitting program that records data, flattens the baseline and calculates peak areas and height. I want to get rid of the laptop and simply put a processor in the instrument with a touch screen. Is this possible with Beaglebone?

I had Labview working on Beagleboard-xM years ago, but the graphic display was horrible. I don’t recall the issue exactly, but their tool required a specific graphical library which I managed to get working, but the quality was very poor (artifacts, etc). Maybe things have improved since then. The guy I worked with back then was Jaidev Amrite (jaidev.amrite@ni.com). I’m not even sure if he still works in the embedded LabView area, but perhaps he can point you in the right directions.

Regards,
John

philippedekleva@gmail.com writes:

I currently use a windows based laptop to run labview developed software
for an analytical instrument I am developing. The software is basically a
curve fitting program that records data, flattens the baseline and
calculates peak areas and height. I want to get rid of the laptop and
simply put a processor in the instrument with a touch screen. Is this
possible with Beaglebone?

If not it sounds like this could be accomplished with a few dozen lines
of Python which would likely be far easier to maintain on a platform
like the BeagleBone.

Cheers,

- Ben

Some info, not sure if its useful:

http://lavag.org/topic/16945-bare-minimum-requirement-for-labview-application-to-run-on-linux/