s-video debian lxde problem

Hello,
I installed debian using this web page:
http://elinux.org/BeagleBoardDebian#Debian_NetInstall
I read about S-video here:
http://elinux.org/BeagleBoardUbuntu#Process_for_setting_up_S-Video
I am a bit confused by this.
What I did was to edit uEnv.txt and used the video output example parameter form this web page:
https://linuxlink.timesys.com/docs/gsg/beagleboard
omapfb.mode=tv:1024x768MR-16@60 omapdss.def_disp=tv
I do get output now on boot via S-Video, but as soon as the graphical environment for LXDE starts up I get blue screen?
It works fine if I do not install a graphical environment, so it seems the changes made in uEnv.txt are taking effect.
Can I not just change uEnv.txt to switch between S-Video and DVI while running LXDE?
Thank you
John

Hello,
I installed debian using this web page:
BeagleBoardDebian - eLinux.org

Hi John,

btw, this script has a "--svideo-ntsc" and "--svideo-pal" options, so
you can set this up correctly..

I read about S-video here:
BeagleBoardUbuntu - eLinux.org
I am a bit confused by this.
What I did was to edit uEnv.txt and used the video output example parameter
form this web page:
Timesys Getting Started Guide for TI BeagleBoard | Timesys LinuxLink
omapfb.mode=tv:1024x768MR-16@60 omapdss.def_disp=tv
I do get output now on boot via S-Video, but as soon as the graphical
environment for LXDE starts up I get blue screen?
It works fine if I do not install a graphical environment, so it seems the
changes made in uEnv.txt are taking effect.
Can I not just change uEnv.txt to switch between S-Video and DVI while
running LXDE?

Well, "uEnv.txt" is a one time/boot only script, so just by changing
it will not allow you to switch between "S-Video" and "DVI" while
running LXDE... You would need to "reboot" to switch..

So to use ntsc s-video, in uEnv.txt set:
defaultdisplay=tv
dvimode=ntsc

(for pal, change "ntsc" to "pal".. untested as i don't have a pal monitor)

For back to dvi, in uEnv.txt set:
defaultdisplay=dvi
dvimode=1280x720MR-16@60

To do it as a run time option to switch between dvi/s-video, please
re-read the kernel dss2 omapfb documentation..

Regards,