SanCloud BeagleBone® Enhanced WiFi 512 - no wlan0 interface


So I have a problem with beaglebone. It doesn’t show wlan0 interface. Flashed latest debian image. connmanctl shows errors of missing property “sv”

sudo /opt/scripts/tools/
model:[SanCloud_BeagleBone_Enhanced]:WiFi AP Broken on Mainline
dogtag:[ Debian Buster IoT Image 2020-04-06]
bootloader:[eMMC-(default)]:[/dev/mmcblk1]:[U-Boot 2019.04-00002-g07d5700e21]:[location: dd MBR]
UBOOT: Booted Device-Tree:[am335x-sancloud-bbe.dts]
UBOOT: Loaded Overlay:[AM335X-PRU-RPROC-4-19-TI-00A0]
UBOOT: Loaded Overlay:[]
UBOOT: Loaded Overlay:[]
UBOOT: Loaded Overlay:[]
/boot/uEnv.txt Settings:
pkg check: to individually upgrade run: [sudo apt install --only-upgrade <pkg>]
groups:[debian : debian adm kmem dialout cdrom floppy audio dip video plugdev users systemd-journal bluetooth netdev i2c gpio pwm eqep remoteproc admin spi iio docker tisdk weston-launch xenomai cloud9ide]
cmdline:[console=ttyO0,115200n8 root=/dev/mmcblk1p1 ro rootfstype=ext4 rootwait coherent_pool=1M net.ifnames=0 lpj=1990656 rng_core.default_quality=100 quiet]
dmesg | grep remote
[   29.016931] remoteproc remoteproc0: wkup_m3 is available
[   29.533303] remoteproc remoteproc0: powering up wkup_m3
[   29.533335] remoteproc remoteproc0: Booting fw image am335x-pm-firmware.elf, size 217168
[   29.533610] remoteproc remoteproc0: remote processor wkup_m3 is now up
[   32.861405] remoteproc remoteproc1: is available
[   32.882673] remoteproc remoteproc2: is available
dmesg | grep pru
[   32.861405] remoteproc remoteproc1: is available
[   32.861568] pru-rproc PRU rproc node pru@4a334000 probed successfully
[   32.882673] remoteproc remoteproc2: is available
[   32.882852] pru-rproc PRU rproc node pru@4a338000 probed successfully
dmesg | grep pinctrl-single
[    0.852769] pinctrl-single 44e10800.pinmux: 142 pins, size 568
dmesg | grep gpio-of-helper
[    0.854520] gpio-of-helper ocp:cape-universal: ready
Bus 001 Device 003: ID 0bda:d723 Realtek Semiconductor Corp.
Bus 001 Device 002: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Please retest with:

That device needs either:

rtl8723bu-modules-uname -r
rtl8821cu-modules-uname -r

Drivers installed…

I think this is fixed in the snapshots…


Thank you for information. Drivers did help.

I ran into the same issue, except with the am335x-debian-11.3-iot-armhf-2022-06-02-4gb.img image.

firmware-realtek/now 20210315-3 all [installed,local]
  Binary firmware for Realtek wired/wifi/BT adapters

rtl8723bu-modules-5.10.109-ti-r45/now 1bullseye armhf [installed,local]
  rtl8723bu modules

These both appear to come pre-installed, but rtl8821cu doesn’t even show up in apt search. Looking at, there doesn’t appear to be any versions of rtl8821cu for the 5.10 kernel?

Any thoughts on what to try next? Is the easy path just to roll back to 10.x instead of 11.x?

Sorry the git repo i used for that driver went eol… i found a fork that has things working upto 5.11.x it’ll be up a few hours, but the package will be available…

and now pushed out…

Just run:

sudo apt update ; sudo apt upgrade ; sudo reboot

You should see:

The following NEW packages will be installed:
  libpruio-modules-5.10.120-ti-r46 linux-image-5.10.120-ti-r46 qcacld-2.0-modules-5.10.120-ti-r46 rtl8723bu-modules-5.10.120-ti-r46
  rtl8821cu-modules-5.10.120-ti-r46 ti-sgx-ti335x-modules-5.10.120-ti-r46
The following packages will be upgraded:
2 upgraded, 6 newly installed, 0 to remove and 0 not upgraded.
Need to get 41.4 MB of archives.


1 Like

@RobertCNelson Seems I was barking up the wrong tree anyway! I tried again tonight with this month’s 11.x build and still couldn’t get wireless working on the Sancloud BB Enhanced, but did find this page: How to Update the BeagleBone® Enhanced (BBE) WiFi Driver - SanCloud

Which links to this repo: GitHub - lwfinger/rtl8723du

I’m going through the build steps here to try that driver out, but there’s big warnings that it’ll need to be rebuilt any time there’s a kernel update… that’s not ideal since I was planning on leaving the BB out at a rural property connected over WiFi.

I’ve got some dpkg stuff I need to brush up on for work next week; if I were to put together all of the necessary bits to build and package this (and send a PR to that repo), would you have any interest in adding this driver to your upstream repo as well?

This kernel module is now starting to roll out to all future kernel builds:

sudo apt update
sudo apt install rtl8723du-modules-`uname -r`

it’ll be automatically added to these kernel update meta-packages…

debian@BeagleBone:~$ sudo apt install
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following additional packages will be installed: libpruio-modules-5.10.120-ti-r47
  linux-image-5.10.120-ti-r47 qcacld-2.0-modules-5.10.120-ti-r47
  rtl8723bu-modules-5.10.120-ti-r47 rtl8723du-modules-5.10.120-ti-r47
  rtl8821cu-modules-5.10.120-ti-r47 ti-sgx-ti335x-modules-5.10.120-ti-r47


You rock. Thank you so much! My rural property is one step closer to having remote frost protection monitoring :slight_smile: