save some cpus/mem/flash


I just got my BBB and I feel the same as many other users, Great Hardware…and here is my 2 cents for software, especially for the pre-load Angstrom linux (in my case: Linux beaglebone 3.8.13 #1 SMP Mon May 20 17:07:58 CEST 2013 armv7l GNU/Linux)

Limit the systemd-journal

I am interested in the system performance when I try new systems, I just use ‘top’ to see which process that eats up CPU and surprisingly, it was this new guy: systemd-journal. When I first booted up the board, it has 500M left and after few minutes or so, it was 300M.
After some search I found the problem:

edit the /etc/systemd/journald.conf and change the following settings:


please reboot to let it take effect.

I think the above settings are especially helpful for the user who is tethering with their PC (just like I did) when they first tried it.

I can’t complain more as I am also a embedded developer but I would think that it is unprofessional to let the kernel debugging message flooding the system, especially for a small embedded system like BBB.

P.S. I am the old guy who is familiar with syslog but not new Hi-tech, it seems that systemd is taking control now, the following are useful commands if you want to check the system log, comparing to the older way…

OLD: tail -1000 /var/log/message
NEW: journalctl -n100

OLD: dmesg
NEW: journalctl -mb

OLD: more /var/log/message
NEW: journalctl



Thanks for this tip!

As for the cause of the journal eating up space, the USB gadget driver for some reason has been compiled with debugging enabled. This causes the RNDIS protocol portion of the driver to generate megabytes of logs per minute.

I haven’t figured out why this has been done, but I was incredibly grateful to see that Robert Nelson turned this off in his latest kernel builds (for Ubuntu and Debian).

I have no idea why Koen is leaving it on for Angstrom. I’ve posted about it a couple times but no one responded.

Thanks a lot, guys! You saved my life!!!
José Henrique

Thanks a lot, guys! You saved my life!!!
José Henrique