Screen Resolution in Ubuntu

I am running Ubuntu Karmic on my Beagle Board. I installed it by
following the instructions at http://elinux.org/BeagleBoardUbuntu.

It's working well, except that the screen resolution is set to
1280x720. This might be good for wide screen monitors, but my monitor
has a 4/3 aspect ratio, so 1024x768 would be better. The GUI tool for
adjusting screen resolution offers no choices other than 1280x720.
Can someone tell me how to change my screen resolution?

I am using the xorg.conf suggested by the installation instructions,
which is:

Restart the beagleboard, and during the startup, use the serial port
to interrupt the countdown, by pressing a key

then enter

setenv dvimode 1024x768MR-24@60
saveenv
boot

and then you can enjoy the resolution you crave :slight_smile:

Brokie

Restart the beagleboard, and during the startup, use the serial port
to interrupt the countdown, by pressing a key

then enter

setenv dvimode 1024x768MR-24@60

A small correction

setenv dvimode 1024x768MR-16@60

setenv dvimode 1024x768MR-16@60
> saveenv
> boot

This does not work for me. If I do that and say "printenv" it shows

dvimode=1024x768MR-16@60

But, the X display still comes up at 1280x720.

I see that this is also specified in a setenv statement in the
boot.scr file. When I change that from 1280x720 to 1024x768 it
doesn't boot at all!

This isn't a big deal. I can use it at 1280x720. But, it would be
nice to change this. It would be especially nice to be able to make
the change without using a serial connection. Having to use the
serial connection makes it difficult to carry the Beagle Board to some
other location and use it with a different display device.

Duane

…If you can run with 1280x720, why not go up to 1280x1024?

Your u-boot determines your resolution since it comes in before the kernel.

ttk

perhaps include the full dump of 'printenv', in case other things have
been changed/your version of u-boot doesn't match those instructions.
and the full boot-scr too if that sets anything.

dear all,

can you copy and paste the steps to be followed for the booting the ubuntu on Beagle board.
i tried with that link but it is showing can’t load kernel image.

I think it's all related to your Bootargs.So pls specify here the
bootcmd and bootarg which u used for booting.

There is two methods, using a boot script (shown below) and the older
and not recommended method which a user sets values directly in
nand...

Just change: omapfb.mode=dvi:1280x720MR-16@60 to what resolution you require...

http://elinux.org/BeagleBoardUbuntu#Create_U-Boot_boot_image

Regards,

Just change: omapfb.mode=dvi:1280x720MR-16@60 to what resolution you require...

I have confirmed that if the resolution is specified in boot.scr, the
specification in NAND has no effect. So, I un-set the dvimode
variable in NAND.

Here are my current environment variables. Note that dvimode is not
set.

Here is my boot.scr file.

---------------------------------------------------------------
' Vߞ��K�d���"v� Ubuntu 9.10�setenv bootcmd 'mmc init; fatload mmc 0:1
0x80300000 uImage; bootm 0x80300000'
setenv bootargs 'console=ttyS2,115200n8 console=tty0 root=/dev/
mmcblk0p2 rootwait rootfstype=ext3 ro vram=12M omapfb.mode=dvi:
1280x720MR-16@60'
boot
---------------------------------------------------------------

This boot.scr works. But, if I change 1280x720 to anything else, the
board does not boot. (I tried 1024x768 and 1280x1024.)

Duane

Hi Duane,

This is a known issue (1,2) 1280x720@60 is about the largest and most
compatible resolution for lcd monitors i've tested... Anything larger
and you start hitting a hardware pixel clock limitation, if your lcd
hardware supports it, you can try bumping down the refresh rate to
50...

1: http://elinux.org/BeagleBoardFAQ#.22DSS2.22_display_driver_for_.3E.3D_2.6.29
2: http://elinux.org/BeagleBoardFAQ#Display_resolutions_.232

Regards,

Thanks folks. I appreciate you help, but I think I have to give up
and add this to the list of things I don't understand.

I know my Beagle Board is capable of 1024x768 because I have Angstrom
on another SD card and it boots to 1024x768 just fine. (There is no
boot.scr on my Angstrom SD card.) But, Ubuntu just won't do it. If I
use anything other than 1280x720 in the boot.scr file I just get the
orange screen. I even tried setting 1024x768 in NAND and removing the
omapfb.mode setting from the boot.scr file, but that didn't work
either.

Duane

This is a known issue (1,2) 1280x720@60 is about the largest and most
compatible resolution for lcd monitors i've tested... Anything larger
and you start hitting a hardware pixel clock limitation, if your lcd
hardware supports it, you can try bumping down the refresh rate to
50...

There's no reason the hardware can't do it - it can do 1280x1024x60Hz
anyway, which is typically what an LCD of that size expects - pixel
clock is 108Mhz. It might go a bit higher too, although I couldn't
get the alternate PLL working, which is needed to get accurate pixel
rates.

(i'm looking at it running that right now, but not inside linux:
http://www.users.on.net/~notzed/beagle/render-rect.img - boot like any
uImage. only written for c3 board)

1: http://elinux.org/BeagleBoardFAQ#.22DSS2.22_display_driver_for_.3E.3D_2.6.29
2: http://elinux.org/BeagleBoardFAQ#Display_resolutions_.232

Note that [2] is only because of limitations in the linux driver (and
the comment isn't quite correct, it doesn't need 'optimising', it just
needs writing, if that comment is still relevent).

you cannot directly modify boot.scr, and then reload it… it needs
to be resigned by signGP to show the size, and the checksum for the
data inside, this may be why you are having issues changing it :slight_smile:

cscrc32("1280x720MR-16@60")!=cscrc32("1024x768MR-16@60"); so the
checksum will fail on load...

Brokie <philtimmes@gmail.com> writes: