Setting the country for wifi (crda)

I’d like to use channel 13 which is not available in the default configuration.
“iw reg get” tells me the country is 00 (not set, i guess)

I edited /etc/default/crda, but it doesn’t change the country.
“iw reg set” works, but only until the next reboot. How do i make this permanent?
On a beaglebone green.

Each of the tools we use by default, connman, wpa_cli, iwd has it’s own option for setting this. How are you connecting to wifi?


1 Like

Ok, I’m using connman. But I can’t find a setting to define the country.

I solved it by creating a file /etc/modprobe.d/wifi-region.conf where I added:
options cfg80211 ieee80211_regdom=DE

Maybe there is a more elegant solution?