Setting up Debian on BBB and PXF cape

Hi guys, great to have this group :slight_smile:

My issue: I got hands on an Erle Brain which is BBB + a PXF cape. I’ve installed a Debian Jessy with a cape manager enabled kernel (4.1.x-ti) as well as bb.org-overlays.

All compiled fine, but the cape is not loaded - see below for more info.

Does nobody know what device tree entry to put inside the slot file for the PXF board?

Thanks lot,

Jan

— slots file ----

debian@beaglebone:/lib/firmware$ cat /sys/devices/platform/bone_capemgr/slots

0: PF---- -1

1: PF---- -1

2: PF---- -1

3: PF---- -1

4: P-O-L- 0 Override Board Name,00A0,Override Manuf,univ-all

----- DMESG -----

debian@beaglebone:/lib/firmware$ dmesg | grep cape

[ 0.000000] Kernel command line: console=tty0 console=ttyO0,115200n8 root=/dev/mmcblk0p1 rootfstype=ext4 rootwait coherent_pool=1M quiet cape_universal=enable

[ 3.760193] bone_capemgr bone_capemgr: Baseboard: ‘A335BNLT,000C,3814BBBK0458’

[ 3.760231] bone_capemgr bone_capemgr: compatible-baseboard=ti,beaglebone-black - #slots=4

[ 3.802319] bone_capemgr bone_capemgr: Invalid signature ‘ffffffff’ at slot 0

[ 3.809566] bone_capemgr bone_capemgr: slot #0: No cape found

[ 3.868126] bone_capemgr bone_capemgr: slot #1: No cape found

[ 3.928123] bone_capemgr bone_capemgr: slot #2: No cape found

[ 3.988122] bone_capemgr bone_capemgr: slot #3: No cape found

[ 3.994036] bone_capemgr bone_capemgr: initialized OK.

[ 113.673499] bone_capemgr bone_capemgr: part_number ‘univ-all’, version ‘N/A’

[ 113.673543] bone_capemgr bone_capemgr: slot #4: override

[ 113.673562] bone_capemgr bone_capemgr: Using override eeprom data at slot 4

[ 113.673580] bone_capemgr bone_capemgr: slot #4: ‘Override Board Name,00A0,Override Manuf,univ-all’