Setting up DHCP and TFTP for beaglebone black

I want to transfer my kernel image to beaglebone black, and the guide mentions that I should have already set up DHCP and tftp on the host machine.

I have set up the TFTP using:

sudo apt-get install tftpd-hpa tftp-hpa

sudo vim /etc/default/tftpd-hpa

TFTP_USERNAME=“tftp”

TFTP_DIRECTORY=“your-ftp-root-directory”

TFTP_ADDRESS=“0.0.0.0:69”

TFTP_OPTIONS="–secure"

sudo service tftpd restart

Also I need a DHCP server on host so It can assign IP to BBBlack.

SO I followed:

sudo apt-get install isc-dhcp-server

sudo /etc/init.d/networking/restart

nano -w /etc/dhcp/dhcpd.conf

default-lease-time 600;

max-lease-time 7200;

option subnet-mask 255.255.255.0;

option broadcast-address 192.168.1.255;

option routers 192.168.1.254;

option domain-name-servers 192.168.1.1, 192.168.1.2;

option domain-name “mydomain.example”;

subnet 192.168.1.0 netmask 255.255.255.0 {

range 192.168.1.10 192.168.1.100;

range 192.168.1.150 192.168.1.200;

} `

ls /etc/default/isc-dhcp-server

INTERFACES “eth0”

eth0 Link encap:Ethernet HWaddr 00:23:ae:15:85:ae
inet6 addr: fe80::223:aeff:fe15:85ae/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:1462 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:279343 (279.3 KB)
Interrupt:16

/etc/network/interface

auto lo
iface lo inet loopback

#auto eth0
iface eth0 inet static
address 192.168.1.2
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.1
up service dhcp3-server restart

Yet. The DHCP is not getting setup.

Please suggest where I may be going wrong