Setting up UART4_RTS to Mode 6

There is no such file on my Beaglebone Rev A5, and I suspect the same is true for your A6.

sudo -i ls /sys/kernel/debug/omap_mux/uart*


/sys/kernel/debug/omap_mux/uart0_ctsn /sys/kernel/debug/omap_mux/uart1_ctsn

/sys/kernel/debug/omap_mux/uart0_rtsn /sys/kernel/debug/omap_mux/uart1_rtsn

/sys/kernel/debug/omap_mux/uart0_rxd /sys/kernel/debug/omap_mux/uart1_rxd

/sys/kernel/debug/omap_mux/uart0_txd /sys/kernel/debug/omap_mux/uart1_txd

You are getting the message because the kernel won’t allow you to create a new file in this directory.

I believe you want to use /sys/kernel/debug/omap_mux/lcd_data13. It’s confusing, but the files are named for their mux mode 0 functions by the software.

Once you find the right file, I suspect you need to echo something different than that to it, also. I have never tried setting bits more significant than the least significant 6 bits (corresponding to hex numbers 3F or less), and I’m not sure what that will be doing.