Sharing Windoze internet connection over USB

I’ve been given a BeagleBoard pocket and I have it plugged into the USB of a windows laptop and have an ssh terminal communication established.
I want to connect it to t’internet and that should be possible through sharing the connection, which I have in the past done with a Raspberry Pi.
Windows tells me that the connection has internet access, but ping gives me:

~$ ping google.com
ping: google.com: Temporary failure in name resolution

Have they changed the system since the instructions were written?
I ask because all the guides I have found say to:

echo “nameserver 8.8.8.8” >> /etc/resolv.conf

Which returns me the error

-bash: /etc/resolv.conf: Permission denied

sudo makes no difference.
ls -l gives:

lrwxrwxrwx 1 root root 24 Apr 6 13:34 /etc/resolv.conf → /run/connman/resolv.conf

Suggesting that resolv.conf is a symbolic link, but the file doesn’t exist.
I’ve tried creating it manually and putting the line in…

And I’ve just tried again and it’s working. I don’t know what I did different to last time, unless it was to leave the quotes out: when I did it with echo, it put the quotes in.

So having written the post and solved my own problem, I’m going to post it anyway, partly by way of “Hello”, but mainly in case anyone else has the same problem.

sudo sh -c "echo 'nameserver 8.8.8.8' >> /etc/resolv.conf"

@RCN: You might want to update the info at the bottom of this page: https://www.digikey.com/en/maker/blogs/how-to-connect-a-beaglebone-black-to-the-internet-using-usb

Sorry, that’s old… It assume’s root… i’ll make a note. thanks!

Regards,

@RCN It may be old, but everything else on the page works. Thanks for all you do to support Beaglebones.