SHT20 I2C temperature sensor isn't detected

Hi all.
I hooked up my sensirion SHT20 temp/humid sensor to my BBB.
http://www.sensirion.com/en/products/humidity-temperature/humidity-sensor-sht20/

-SHT20- -BBB-
GND —> P9-01
VDD —> P9-03
SCL —> P9-19
SDA —> P9-20

The datasheet says the address is 01000000 (0x40).

5.3 Sending a Command
After sending the Start condition, the subsequent I2C
header consists of the 7-bit I2C device address ‘1000’000’
and an SDA direction bit (Read R: ‘1’, Write W: ‘0’).
The wiring is like the following.

I expected to appear the sensor on I2C-1’s address 0x40.
But it isn’t detected:

$ sudo i2cdetect -r -y 1

0 1 2 3 4 5 6 7 8 9 a b c d e f

00: – -- – -- – -- – -- – -- – -- –

10: – -- – -- – -- – -- – -- – -- – -- – --

20: – -- – -- – -- – -- – -- – -- – -- – --

30: – -- – -- – -- – -- – -- – -- – -- – --

40: – -- – -- – -- – -- – -- – -- – -- – --

50: – -- – -- UU UU UU UU – -- – -- – -- – --

60: – -- – -- – -- – -- – -- – -- – -- – --

70: – -- – -- – -- – --

and also

$ sudo i2cdetect -r -y 0

0 1 2 3 4 5 6 7 8 9 a b c d e f

00: – -- – -- – -- – -- – -- – -- –

10: – -- – -- – -- – -- – -- – -- – -- – --

20: – -- – -- UU – -- – -- – -- – -- – -- –

30: – -- – -- UU – -- – -- – -- – -- – -- –

40: – -- – -- – -- – -- – -- – -- – -- – --

50: UU – -- – -- – -- – -- – -- – -- – -- –

60: – -- – -- – -- – -- – -- – -- – -- – --

70: UU – -- – -- – -- –

I checked the sensor worked as a normal I2C device on my Arduino.

Do I need to install some drivers on BBB for the sensor?
Or do I missed some procedures?

Maybe you need pull up resistors? The revision B of the Weather Cape also uses a Sensirion humidity sensor SHT21:
http://elinux.org/CircuitCo:BeagleBone_Weather

-Hieu