Silent boot with 2015-07-17 release for Beagleboneblack

Hi,

i tried to set optargs= quiet or optargs= silent in boot/uEnv.txt to get a silent boot ( only splash screen with no boot info on video).
What are the right settings to get it ?

Thanks,

Mirko

Corresponding line is bold / italic.

debian@beaglebone:~$ sudo nano /boot/uEnv.txt

#Docs: http://elinux.org/Beagleboard:U-boot_partitioning_layout_2.0

uname_r=4.1.2-ti-r3
#dtb=
cmdline=quiet init=/lib/systemd/systemd

##Example
#cape_disable=capemgr.disable_partno=
#cape_enable=capemgr.enable_partno=

##Disable HDMI/eMMC
#cape_disable=capemgr.disable_partno=BB-BONELT-HDMI,BB-BONELT-HDMIN,BB-BONE-EMMC-2G

##Disable HDMI
#cape_disable=capemgr.disable_partno=BB-BONELT-HDMI,BB-BONELT-HDMIN

##Disable eMMC
#cape_disable=capemgr.disable_partno=BB-BONE-EMMC-2G

##Audio Cape (needs HDMI Audio disabled)
#cape_disable=capemgr.disable_partno=BB-BONELT-HDMI
#cape_enable=capemgr.enable_partno=BB-BONE-AUDI-02

##enable BBB: eMMC Flasher:
##make sure, these tools are installed: dosfstools rsync
#cmdline=init=/opt/scripts/tools/eMMC/init-eMMC-flasher-v3.sh

Thank you William,

now i have splash screen and then:

Debian GNU/Linux 7

BeagleBoard.org Debian Image 2015-07-17

Support/FAQ: http://elinux.org/Beagleboard:BeagleBoneBlack_Debian

default username:password is [debian:temppwd]

root@192.168.7.2’s password:

i would like to start automatically an application without display this, it it possible ?

Thank you William,

now i have splash screen and then:

Debian GNU/Linux 7

BeagleBoard.org Debian Image 2015-07-17

Support/FAQ: http://elinux.org/Beagleboard:BeagleBoneBlack_Debian

default username:password is [debian:temppwd]

root@192.168.7.2’s password:

i would like to start automatically an application without display this, it it possible ?

Unfortunately that image most likely uses systemd by default, and I’m not very good with systemd startup scripts. As for the login message, not sure why it resides but if you google “debian ssh login text” you can probably find out for yourself.

Debian GNU/Linux 7

BeagleBoard.org Debian Image 2015-03-01

Support/FAQ: http://elinux.org/Beagleboard:BeagleBoneBlack_Debian

default username:password is [debian:temppwd]

This part of the message come from /etc/issue.net, and the rest of the message comes from /etc/motd. I’m not sure of the implications of removing the file /etc/issue.net, but it is configured in /etc/ssh/sshd_config under the Banner configuration option. If you open the file then scroll to the bottom you should see: Banner /etc/issue.net

So, a couple options. You can delete the entire contents of the file, or in /etc/ssh/sshd_config you can comment out the Banner line with a # like the line directly above it. In /etc/motd, I’m fairly sure, but not 100% positive you can change this to say whatever you like. motd === message of the day, which if memory serves correctly is modifiable.

thanks William

I tried several solutions but i have not found the way to start my application before than login prompt has displayed.
Even if i start my application in rc.local where it is supposed to start before than the login prompt.
What i do not understand is why in a previous release with the same sysinit settings the login prompt was displayed at the end of the application.

"quiet loglevel=0" should nuke even more...

Regards,

Thank you Robert.

It worked as i removed “init=/lib/systemd/systemd” and kept “quiet loglevel=0”.
So now i get what i wanted:

the application starts at the end of the other init scripts (in rc.local) and the login

prompt is displayed only when application is stopped.

Anyway i’d like to know if init= /lib/systemd/systemd is necessary and why removing that i have a similar boot except for the login prompt.

In wheezy that line activates systemd vs the default of sysvinit.

So when you later upgrade to a newer distro that uses systemd by
default, your going to have to fix your init script. :wink:

Regards,

good to know :slight_smile:

Thanks

So when you later upgrade to a newer distro that uses systemd by
default, your going to have to fix your init script. :wink:

Or in the case of Jessie http://without-systemd.org/wiki/index.php/How_to_remove_systemd_from_a_Debian_jessie/sid_installation

Seem I’m far from alone in not making the leap to systemd yet. As there are multiple wiki / post on how to remove it :wink:

William:
To the extent I have used it, it seems to work fine and is easy to learn and manage.
It is potentially replacing a number of separate old functions that some people are familiar with.
Being a relative new student of Linux, I don’t see a problem with it. I would rather learn one system
than five separate systems that all together end up providing the same result.
— Graham

hi

May I ask how do you get the splash screen? seems like you are using the image from the beagleboard.org? Do you need to rebuild the image?

Thanks
/pli

在 2015年7月29日星期三 UTC+2上午7:57:10,William Hermans写道: