SIMPLE MODULE HELP!!

i have done application level and driver programming but for intel x86 machine. I got my beaglebone…and the image (Angstrom-Cloud9-IDE-GNOME-eglibc-ipk-v2012.05-beaglebone-2012.04.22.img.xz)… working fine. so i wanted to run a simple hello world kernel module…but the /usr/src/linux’uname -r’ doesnt contain the required file. So after searching a lot i started to rebuild the kernel using openembedded way.

git clone git://github.com/Angstrom-distribution/setup-scripts.git

MACHINE=beaglebone ./oebb.sh config beaglebone
MACHINE=beaglebone ./oebb.sh update
MACHINE=beaglebone ./oebb.sh bitbake virtual/kernel

I was successful is making the virtual/kernel.
In the post in the same group Jerril pointed out to copy some of the headers file from virtual/kernel to /usr/src/linux.
So i tried but the problem is that the folder already contains a “include” and "the virtual/kernel output also contain a “include” folder … so what should i do.

I doubt is that the write way …
If you have got a hint … pass it to me …thanks

after completing the above steps…that is copying …
I tried making the modules … the output is as follows:

root@beaglebone:/usr/src/linux-3.2.18# make modules
CHK include/linux/version.h
CHK include/generated/utsrelease.h
make[1]: include/generated/mach-types.h' is up to date. make[1]: *** No rule to make target kernel/bounds.c’, needed by `kernel/bounds.s’. Stop.
make: *** [prepare0] Error 2

But “make scripts” executed without any problem.

I posted a guide to building kernel modules on the Beaglebone that may be helpful to you: http://www.cemetech.net/forum/viewtopic.php?t=7814