slic3r on BBB?

does any one have slic3r running on the BBB? Any distro is fine.


Slic3r was added to the unstable and testing versions of Debian a
few days ago, and armhf (the relevant one for BBB) is included in the
architecture list for the package, so apt-get is your friend.


I haven't tried it yet on arm, but slic3r has just entered debian
testing: you may try with that package

Thanks, David and Elena. No luck with the repos enabled on the May-14 Debian image. Though I suspect because the image is based on Wheezy, and the new slic3r package is in Jesse.

Anyone (Robert C Nelson, etc) know of an image for Jesse for BBB or instructions I could follow to build an image?


Here’s my BBB:

root@beaglebone:~# apt-cache search slic3r

root@beaglebone:~# cat /etc/issue
Debian GNU/Linux 7 \n \l

default username:password is [debian:temppwd]


The IP Address for usb0 is:

root@beaglebone:~# uname -a
Linux beaglebone 3.8.13-bone50 #1 SMP Tue May 13 13:24:52 UTC 2014 armv7l GNU/Linux

root@beaglebone:~# ls /etc/apt/sources.list.d/


root@beaglebone:~# cat /etc/apt/sources.list
deb wheezy main contrib non-free
#deb-src wheezy main contrib non-free

deb wheezy-updates main contrib non-free
#deb-src wheezy-updates main contrib non-free

deb wheezy/updates main contrib non-free
#deb-src wheezy/updates main contrib non-free

#deb wheezy-backports main contrib non-free
##deb-src wheezy-backports main contrib non-free

deb [arch=armhf] wheezy-bbb main
#deb-src [arch=armhf] wheezy-bbb main

I've been working on some new features, so here's a basic jessie
image. (just make sure you blank out the eMMC, otherwise it won't


You sure are fast, Robert! Thanks

I burned jesse image but uboot didn’t like find anything to boot (seen via ftdi cable)

(just make sure you blank out the eMMC, otherwise it won’t boot…)

Is this some explicit action I need to do to the eMMC before booting off uSD with the jessie image?


Just hold down the boot button, then once booted:

mkdir ./disk
sudo mount /dev/mmcblk1p1 ./disk
sudo rm -f ./disk/MLO
sudo umount /dev/mmcblk1p1



Thanks all! apt-get install slic3r worked like a charm. Waiting for lxde to install now.

log from my shell for those interested:

Thanks again to all in this thread, after LXDE installed, I am able to run Slic3r GUI and successfully turned the Boris STL from Jason into gcode with it :slight_smile:


I’m quite please at this because our Chicago Public Library Maker Lab now has a Lulzbot TAZ (100% Open Source :slight_smile: but they don’t have rights to install slic3r on their Windows PCs in the lab (it takes long time for IT dept to install). So I’ve set up a BeagleBone Black their which they can run Slic3r on! Next step is to get printrun and pronterface running but the Lulzbot TAZ 4 has a nice LCD controller with SD card reader so its not as critical as Slic3r.


Drew, I’ve never heard of that app until now, but is the BBB really the best system to run that on ? Just curious as it looked something akin to Wings3D( ltos of graphics intensive stuff )

If it works it works though just curious.

I don’t think graphics heavy but it is CPU heavy. A full x86 computer would be better but the BBB speed at slicing was livable if a bit annoying. Like about 2 min for Boris beagle STL.

Plus BBB is great for situation where the existing PCs in this lab require slow process to get admins to install software. I also get warm fuzzies cus its 100% open source hardware and software solution including the 3d printer :slight_smile:

Ah, ok I can understand that.

I guess mostly because I’m a hobbyist with my own systems, etc. That I forget some people in a professional environment may have issues with such things.

The BBB will rapidly run out of memory and CPU for slicing complex
models. There are some files that even give 32-bit x86 installs
problems (needing the extra RAM available per-process on a 64-bit build).

...but it's definitely handy being able to slice simpler models directly
on the 'Bone, and some of the memory usage issues have been greatly
improved with more recent versions of Slic3r.