SPI disappears when cape plugged in?

I have a Beaglebone Black with a recent Debian image that I loaded, we have some SPI hardware on one of those proto-board things, which works totally fine without the cape installed.
Then we have pass through pins and a cell network modem cape sitting on top of that, which seems to work just fine on its own.

Ultimately I need both of these things working at once, but with the cape plugged in, SPI disappears entirely and I can’t seem to do anything to get it to load (echo BB-SPIDEV-0 > capemgr/slots does nothing, and modprobe does nothing).
Does anybody know why this is and have a solution?

Overlays get loaded on boot these days
check /boot/uEnv.txt to see whats loaded

Thanks for the reply,
I believe I’ve already gone into the uEnv.txt and tried to explicitly do things like disable HDMI and enable the two SPI ports, (if I remember right I added those to “enable_partno=” or whatever the syntax was).

But when I boot with the cape plugged in it seems to have no effect.

OK, my possible understanding at this point is this:

Cape EEPROM has a name string on it.
BBB looks at that name string first and loads the matching file device tree.
For some reason, no other device tree overlays are loaded. SPI is not a part of the overlay for this cape (confirmed by looking at their dts on github).

I’m not really sure why it wouldn’t let me go ahead and load the BB-SPIDEV overlays from user space once the OS is already booted, or totally ignore them in uEnv.txt.

But it seems to me the possible solutions are:
Add everything I need to the dts for this cape, recompile it and copy it into the right place on my BBB
Or, just take the existing compiled cape-universal dtbo and copy it into the file named to match this cape, and let that be what gets loaded.

Option #2 seems less tedious for a first crack…

Any other thoughts and comments welcome.

Update if anyone’s curious,
I actually tried temporarily pulling the cape’s corresponding overlay from /lib/firmware (I think that’s where it was) and booting up that way, and SPI came back, so I believe that may solve my problem, otherwise I just have to modify and re-build that cape.