ssh server in Angstrom


I've compiled Angstrom console filesystem. SSH server seems to be
installed but not enabled. How can I enable it? If I use gnome demo
from Koen SSH server is enabled there.

Thanks in advance!

On your console image, do a 'opkg list-installed | grep -i ssh' and
see what you get. You may have client (dropbear) but not ssh server.



dropbear is both client and server :slight_smile:

You got me :slight_smile: We kind of went through this recently ... had a
requirement for openssh and we had client & no server. Haven't worked
with dorpbear in a while ... good to know it does both!


Ssh server is already installed but either not configured or disabled. I even tried to opkg remove and installed the package agian. Anyway trying to connect from a PC gives a message “connection refused”. Did not dig deep and asked here for help.

If you force dropbear to start (just "dropbear" in the command line; it will start as a deamon), does it work?

Systemd is not starting it in my beagle right now, I do not know why. Starting it manually works, though.

To get the status of the dropbear service:
systemctl status dropbear.service

If the dropbear service is not running or not enabled:
systemctl enable dropbear.service
systemctl start dropbear.service