SSH to newly flashed board: won't accept an empty password (PuTTY on Windows 7 to Angstrom)

I have a beaglebone black that was working very well earlier today. I was connecting to it over the USB cord using both Serial and SSH.
When I use PuTTY to open a SSH connection, it asks what I want to login as (“root”), and then for the password (which should be empty, right?). It reports however, that access is denied. I’ve included a picture of the window.
When I use a serial connection instead, it displays the angstrom logo, asks for a beagleboard login (“root”), doesn’t ask for a password, and works fine.

I tried reflashing it, but it does the same thing. Any suggestions? Thank you!

try root as a password

Thank you for the reply. I have tried root as the password (and just did again for good measure), and I get the same access denied message.

Do you by any chance also have a display you are successfully connecting to your BBB?
If so, open a terminal on the BBB itself and enter the command: xhost +

Then try and connect using SSH. No guarantees.