SSH to the BBB

Hello all,

I noticed a very strange thing when booting my BBB.

First of all I am booting angstrom from my SD card ( Angstrom-Cloud9-IDE-GNOME-eglibc-ipk-v2012.12-beaglebone-2013.05.24.img.xz).

The system will boot but I cannot SSH to the board. I am powering the board with the USB (of course) and the external power. But the strange thing is that sometimes I can connect to the board, it’s kind of hit and miss. At first, if I connect to the board with the USB first and then after the lights go on I connect the external power, then it will work. But after awhile, it’s the external power first and then the USB. Changes all the time…

Your help is appreciated!


If DC is plugged in, the USB power is not connected. In order to connect via SSH USB must be connected, not for power reasons, but USB reasons.


Hi Gerald,

But I do not connect the external power at all, it will definitely not work. So I am not sure what you mean if DC power is plugged in, the USB power is not connected. Because I have managed to get it working with both both powers plugged in to the board.

That means in your case your DC from the USB is not good and you need the DC from the external DC supply in order for your board to work. Correct?


That is correct.

The strange thing, however, is that when I was booting from the eMMC with the BBB flasher, I can boot with just the USB and no need of the external power; but now that I am booting from the SD card, USB alone doesn’t work.


That is because the uSD takes more current. Something your USB power cannot provide. Therefore you need more current, which the DC connection can supply.


Ok, you just told me that I need to use the DC connection. But you also told me that if I connect the board with DC power, the USB doesn’t work.

So how do I SSH to the board without USB connect? And I tried ethernet, and it doesn’t work.

You cannot do SSH without USB. USB has power. USB had data lines as well. USB is the communication channel to the PC.

DC supplies more current. You need them both

USB=Serial communication of data.


I understand that, but the problem is that it doesn’t work for my board as I indicated in the original post.

Let’s start over. What does the start.htm page look like when you activate it?


I saved the webpage in a zip file.

start.tar.gz (4.71 MB)

OK. So that means you have th epower you need.
The board is booting proplerly.
Your =inability to SSH has nothing to do in my opionin with power.

You need to look elsewhere for your issue with not being able to SSH, which by the way a LOT of people have had. Search the forum for those discussion and use that information to see if you can solve your problem.


But Gerald, the problem that I am having is that sometimes it works but sometimes it doesn’t. I just managed to get the board working, but if I disconnect it now, it will take me a number of tries to get it working again.

If I can load the start webpage, I can SSH to the board. But a lot of times the start page will not load at all.

Does this sound like a hardware issue?

I suppose you may have a grounding issue. All the parts in the system must be connected to the same ground.

The fact that is does work sometime indicates the the HW is capable of performing the desired function.

You can request an RMA and have it checked out if you like. But i would not expect them to find anything.


for the love of mutt, can people stop posting multi-megabyte files
to the mailing list? it's like some of you don't understand how the
internet works or something.


I tried it with another BBB, and exactly the same problem. Sometimes it will connect and sometimes it will not.

I have the same probleme like Jack.
Does anyone has an answer?

Thank you