Static IP for bridge

I’ve almost given up on this. I’m trying to configure a bridge between wlan0 and eth0. I can make that work. My problem is that
my BBB rev C refuses to follow my orders.

I do not want dhclient running on eth0 and something keeps starting it. This is causing problems for the bridge. There should be no IP address on eth0.

What I think that is going on is that when eth0 is up (added to bridge) that ifup is being called. It seems to be unaware of /etc/network/interfaces.

How can I fix this?

root@beaglebone:~# ps -ef | grep dhclient
root 1687 1 0 20:39 ? 00:00:00 dhclient -v -pf /run/dhclient.br0.pid -lf /var/lib/dhcp/dhclient.br0.leases br0
root 2697 1 0 20:39 ? 00:00:00 /sbin/dhclient -v eth0

root@beaglebone:~# cat /etc/default/networking

Configuration for networking init script being run during

the boot sequence

Set to ‘no’ to skip interfaces configuration on boot

#CONFIGURE_INTERFACES=yes

Don’t configure these interfaces. Shell wildcards supported/

EXCLUDE_INTERFACES=“eth0”

Set to ‘yes’ to enable additional verbosity

#VERBOSE=no

root@beaglebone:~# cat /etc/network/interfaces

This file describes the network interfaces available on your system

and how to activate them. For more information, see interfaces(5).

The loopback network interface

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet manual
pre-up ifconfig $IFACE up
pre-down ifconfig $IFACE down

auto wlan0
iface wlan0 inet manual
pre-up ifconfig $IFACE up
pre-down ifconfig $IFACE down

auto br0
iface br0 inet dhcp
bridge_ports eth0
bridge_stp on

Ethernet/RNDIS gadget (g_ether)

… or on host side, usbnet and random hwaddr

Note on some boards, usb0 is automaticly setup with an init script

iface usb0 inet static
address 192.168.7.2
netmask 255.255.255.0
network 192.168.7.0
gateway 192.168.7.1