Static IP with connman solved


I just wanted to report an error that occurred to me and how I solved it.

I installed a new version of Debian on Beaglebone Black, which was made available at by Robert Nelson.
I use static IP on Ethernet and configure it via connman as follows:

  1. Discover the identification of the ethernet interface:
    ls -la /var/lib/connman
    drwx------ 2 root root 4096 Jul 19 15:37 ethernet_b0d5ccfbbc59_cable <=== this is my MAC Address

  2. Configure static IP:
    connmanctl config ethernet_b0d5ccfbbc59_cable --ipv4 manual

  3. Configure DNS (this can be done together with the previous command):
    connmanctl config ethernet_b0d5ccfbbc59_cable --nameservers

When executing item 1, the following error was displayed:
Method “SetProperty” with signature “sv” on interface “net.connman.Service” doesn’t exist

Running “connmanctl services” no interface was displayed:
root@beaglebone:~# connmanctl

<====== Here should appear “ethernet_b0d5ccfbbc59_cable” or “ethernet”, I do not know …

The connman is already configured for dynamic ip, so I did the following:
1- connect the Beaglebone to the router;
2- check which IP the Beaglebone registered;
3) access the Beaglebone for this dynamic IP;
4) run the command: connmanctl config ethernet_b0d5ccfbbc59_cable --ipv4 manual
5) You will lose the connection after executing item 4, then just access the BBB again using the new IP, which in my case is

I was getting the same error changing from DHCP to manual
Just in case anyone else has this issue, I still had to set the gateway to if it wasn’t used

root@beaglebone:/# connmanctl services
*AO Wired ethernet_985dad474bf3_cable


root@beaglebone:/# connmanctl config ethernet_985dad474bf3_cable --ipv4 manual --nameservers
Error ‘’: Invalid argument
Error ‘’: Invalid argument
Error ethernet_985dad474bf3_cable: Method “SetProperty” with signature “sv” on interface “net.connman.Service” doesn’t exist

root@beaglebone:/# connmanctl config ethernet_985dad474bf3_cable --ipv4 manual --nameservers


Curious if anyone has had any success with trying to apply settings with the ethernet cable unplugged ?. I get this same error when trying to do so. Although I can’t use ‘connmanctl services’ with the cable unplugged, I can still use my MAC address to fill in the . When trying I ultimately get the error: Method “SetProperty” with signature “sv” on interface “net.connman.Service” doesn’t exist