Stopping gnome-session on startup

All,

Can anyone point me in the right direction?

I’m using my BBB as a headless terminal. When I boot it up, it always has gnome-session running and taking up cycles. I don’t need it running. I can stop it with:

systemctl stop gdm.service

The question is: how do I stop it from running at startup in the first place?

Thanks,

Trefor

Have you tried:

systemctl disable gdm.service

…then re-booting?

From manpage systemctl:

disable [NAME...]
           Disables one or more units. This removes all symlinks to the
           specified unit files from the unit configuration directory, and
           hence undoes the changes made by enable. Note however that this
           removes all symlinks to the unit files (i.e. including manual
           additions), not just those actually created by enable. This call
           implicitly reloads the systemd daemon configuration after
           completing the disabling of the units. Note that this command does
           not implicitly stop the units that is being disabled. If this is
           desired an additional stop command should be executed afterwards.

           This command will print the actions executed. This output may be
           suppressed by passing --quiet.

           This command honors --system, --user, --global in a similar way as
           enable.

Don

Thanks Don.

That doesn’t seem to work. After a reboot, it’s still running.

Trefor

Does gdm also provide the auto-mounter service that mounts usb flash drives (and the drive in the sd card slot if it’s not the one you are booting from?)

I thought it would be a good idea to save the ram and cpu and disabled the gdm only to find that my extra storage wasn’t being mounted in /media/, though it could have been something else I was fiddling with at the time.

Wim.

Don,

Really sorry - did this again and it works fine. I must have made a mistake and not pasted correctly.

Thanks for your help.