Strange Characters after Login to BeagleBone on Debian Squeezy

Hi *,

I installed debian on beaglebone A5.

Mac OS X: When I try to connect to the beaglebone the configuration screens apear in strange characters.
Navigation through the configuration screens is possible.
Intel Host with OpenSuse 12.2 64 Bit. The Menues are displayed in “readable” characters, but navigation is impossible.

Perhaps you have an idea?
Thanks in Advance,
Gerrit

Screenshoot (Mac OS X Mountain Lion)

┌───────────────────────┤ [!!] S␊┌␊␌├ ▒ ┌▒┼±┤▒±␊ ├────────────────────────┐
│ │
│ C␤⎺⎺⎽␊ ├␤␊ ┌▒┼±┤▒±␊ ├⎺ ␉␊ ┤⎽␊␍ °⎺⎼ ├␤␊ ␋┼⎽├▒┌┌▒├␋⎺┼ ⎻⎼⎺␌␊⎽⎽. T␤␊ │
│ ⎽␊┌␊␌├␊␍ ┌▒┼±┤▒±␊ ┬␋┌┌ ▒┌⎽⎺ ␉␊ ├␤␊ ␍␊°▒┤┌├ ┌▒┼±┤▒±␊ °⎺⎼ ├␤␊ ␋┼⎽├▒┌┌␊␍ │
│ ⎽≤⎽├␊└. │
│ │
│ L▒┼±┤▒±␊: │
│ │
│ C │
│ E┼±┌␋⎽␤ │
│ │
│ <G⎺ B▒␌┐> │
│ │
└─────────────────────────────────────────────────────────────────────────┘

<T▒␉> └⎺┴␊⎽; <S⎻▒␌␊> ⎽␊┌␊␌├⎽; <E┼├␊⎼> ▒␌├␋┴▒├␊⎽ ␉┤├├⎺┼⎽

During boot the text encoding is right. Everything is readable.

This came up on irc a few weeks ago, retry with screen already
running, hitting the reset button on the BeagleBone..

Here's what Debian Wheezy shows with:

voodoo@work-e6400:~$ screen --version
Screen version 4.01.00devel (GNU) 2-May-06

screen /dev/ttyUSB0 115200

  ┌───────────────────────┤ [!!] Select a language ├────────────────────────┐
  │ │
  │ Choose the language to be used for the installation process. The │
  │ selected language will also be the default language for the installed │
  │ system. │
  │ │
  │ Language: │
  │ │
  │ C │
  │ English │
  │ │
  │ <Go Back> │
  │ │
  └─────────────────────────────────────────────────────────────────────────┘

<Tab> moves; <Space> selects; <Enter> activates buttons

Regards,

Hi Robert,

I did that for many times. No Success.
Kind regards,
Gerrit

Well, then I can't help you... It works with Debian's screen... It
also works great with gtkterm in Debian.. The user on irc, not sure
which version of Mac OSX he was running...

Regards,

On OpenSuse 12.2 the configuration section displays well. But no keyboard
inputs will be accepted …

extopt/bb/debian/netinstall # screen /dev/ttyUSB0 115200

<>

U-Boot SPL 2013.01.01-00006-gf1c06e5 (Feb 04 2013 - 10:59:41)
OMAP SD/MMC: 0
reading u-boot.img
reading u-boot.img

U-Boot 2013.01.01-00006-gf1c06e5 (Feb 04 2013 - 10:59:41)

I2C: ready
DRAM: 256 MiB
WARNING: Caches not enabled
NAND: No NAND device found!!!
0 MiB
MMC: OMAP SD/MMC: 0, OMAP SD/MMC: 1
*** Warning - readenv() failed, using default environment

musb-hdrc: ConfigData=0xde (UTMI-8, dyn FIFOs, bulk combine, bulk split, HB-ISO Rx, HB-ISO Tx, SoftConn)
musb-hdrc: MHDRC RTL version 2.0
musb-hdrc: setup fifo_mode 4
musb-hdrc: 28/31 max ep, 16384/16384 memory
USB Peripheral mode controller at 47401000 using PIO, IRQ 0
musb-hdrc: ConfigData=0xde (UTMI-8, dyn FIFOs, bulk combine, bulk split, HB-ISO Rx, HB-ISO Tx, SoftConn)
musb-hdrc: MHDRC RTL version 2.0
musb-hdrc: setup fifo_mode 4
musb-hdrc: 28/31 max ep, 16384/16384 memory
USB Host mode controller at 47401800 using PIO, IRQ 0
Net: cpsw, usb_ether
Hit any key to stop autoboot: 0
mmc0 is current device
SD/MMC found on device 0
reading uEnv.txt
707 bytes read in 5 ms (137.7 KiB/s)
Loaded environment from uEnv.txt
Importing environment from mmc …
reading zImage.net
2660560 bytes read in 310 ms (8.2 MiB/s)
reading initrd.net
10201506 bytes read in 1172 ms (8.3 MiB/s)
Booting from mmc …

Starting kernel …

Uncompressing Linux… done, booting the kernel.
[ 0.000000] Initializing cgroup subsys cpuset
[ 0.000000] Initializing cgroup subsys cpu
[ 0.000000] Linux version 3.2.33-psp26 (root@panda-es-1gb-a3) (gcc version 4.6.3 (Debian 4.6.3-14) ) #1 Wed Jan 9 04:07:02 UTC 2013
[ 0.000000] CPU: ARMv7 Processor [413fc082] revision 2 (ARMv7), cr=10c53c7d
[ 0.000000] CPU: PIPT / VIPT nonaliasing data cache, VIPT aliasing instruction cache
[ 0.000000] Machine: am335xevm
[ 0.000000] Memory policy: ECC disabled, Data cache writeback
[ 0.000000] AM335X ES1.0 (sgx neon )
[ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pages: 65024
[ 0.000000] Kernel command line: console=ttyO0,115200n8 VIDEO_DISPLAY root=/dev/ram0 rw ip=
[ 0.000000] PID hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.000000] Dentry cache hash table entries: 32768 (order: 5, 131072 bytes)
[ 0.000000] Inode-cache hash table entries: 16384 (order: 4, 65536 bytes)
[ 0.000000] allocated 1048576 bytes of page_cgroup
[ 0.000000] please try ‘cgroup_disable=memory’ option if you don’t want memory cgroups
[ 0.000000] Memory: 256MB = 256MB total
[ 0.000000] Memory: 241232k/241232k available, 20912k reserved, 0K highmem
[ 0.000000] Virtual kernel memory layout:
[ 0.000000] vector : 0xffff0000 - 0xffff1000 ( 4 kB)
[ 0.000000] fixmap : 0xfff00000 - 0xfffe0000 ( 896 kB)
[ 0.000000] vmalloc : 0xd0800000 - 0xff000000 ( 744 MB)
[ 0.000000] lowmem : 0xc0000000 - 0xd0000000 ( 256 MB)
[ 0.000000] modules : 0xbf000000 - 0xc0000000 ( 16 MB)
[ 0.000000] .text : 0xc0008000 - 0xc06ab000 (6796 kB)
[ 0.000000] .init : 0xc06ab000 - 0xc06e9000 ( 248 kB)
[ 0.000000] .data : 0xc06ea000 - 0xc07331a0 ( 293 kB)
[ 0.000000] .bss : 0xc07331c4 - 0xc077469c ( 262 kB)
[ 0.000000] NR_IRQS:410 nr_irqs:410 410
[ 0.000000] IRQ: Found an INTC at 0xfa200000 (revision 5.0) with 128 interrupts
[ 0.000000] Total of 128 interrupts on 1 active controller
[ 0.000000] OMAP clockevent source: GPTIMER2 at 24000000 Hz
[ 0.000000] OMAP clocksource: GPTIMER1 at 32768 Hz
[ 0.000000] sched_clock: 32 bits at 32kHz, resolution 30517ns, wraps every 131071999ms
[ 0.000000] Console: colour dummy device 80x30
[ 0.000183] Calibrating delay loop… 548.86 BogoMIPS (lpj=2744320)
[ 0.048339] pid_max: default: 32768 minimum: 301
[ 0.048492] Security Framework initialized
[ 0.048583] AppArmor: AppArmor initialized
[ 0.048614] Mount-cache hash table entries: 512
[ 0.049072] Initializing cgroup subsys cpuacct
[ 0.049133] Initializing cgroup subsys memory
[ 0.049194] Initializing cgroup subsys devices
[ 0.049194] Initializing cgroup subsys freezer
[ 0.049194] Initializing cgroup subsys blkio
[ 0.049224] Initializing cgroup subsys perf_event
[ 0.049346] CPU: Testing write buffer coherency: ok
[ 0.050415] devtmpfs: initialized
[ 0.071044] omap_hwmod: gfx: failed to hardreset
[ 0.087768] omap_hwmod: pruss: failed to hardreset
[ 0.088653] print_constraints: dummy:
[ 0.088928] NET: Registered protocol family 16
[ 0.090240] OMAP GPIO hardware version 0.1
[ 0.091552] omap_mux_init: Add partition: #1: core, flags: 0
[ 0.093078] omap_i2c.1: alias fck already exists
[ 0.093505] hw-breakpoint: debug architecture 0x4 unsupported.
[ 0.093719] omap2_mcspi.1: alias fck already exists
[ 0.093841] omap2_mcspi.2: alias fck already exists
[ 0.093933] omap_init_sham: platform not supported
[ 0.093963] omap_init_aes: platform not supported
[ 0.094055] edma.0: alias fck already exists
[ 0.094085] edma.0: alias fck already exists
[ 0.094085] edma.0: alias fck already exists
[ 0.094207] cape: pcm register
[ 0.103881] bio: create slab at 0
[ 0.105468] SCSI subsystem initialized
[ 0.106475] usbcore: registered new interface driver usbfs
[ 0.106628] usbcore: registered new interface driver hub
[ 0.106811] usbcore: registered new device driver usb
[ 0.107177] registerd cppi-dma Intr @ IRQ 17
[ 0.107177] Cppi41 Init Done Qmgr-base(d083a000) dma-base(d0838000)
[ 0.107208] Cppi41 Init Done
[ 0.107238] musb-ti81xx musb-ti81xx: musb0, board_mode=0x13, plat_mode=0x3
[ 0.107421] musb-ti81xx musb-ti81xx: musb1, board_mode=0x13, plat_mode=0x1
[ 0.107971] omap_i2c omap_i2c.1: bus 1 rev2.4.0 at 100 kHz
[ 0.108917] tps65910 1-002d: could not be detected
[ 0.109497] Advanced Linux Sound Architecture Driver Version 1.0.24.
[ 0.110137] NetLabel: Initializing
[ 0.110168] NetLabel: domain hash size = 128
[ 0.110168] NetLabel: protocols = UNLABELED CIPSOv4
[ 0.110229] NetLabel: unlabeled traffic allowed by default
[ 0.110290] Switching to clocksource gp timer
[ 0.110534] AppArmor: AppArmor Filesystem Enabled
[ 0.122924] musb-hdrc: version 6.0, ?dma?, otg (peripheral+host)
[ 0.123138] musb-hdrc musb-hdrc.0: dma type: dma-cppi41
[ 0.123352] MUSB0 controller’s USBSS revision = 4ea20800
[ 0.124206] musb-hdrc musb-hdrc.0: USB OTG mode controller at d081c000 using DMA, IRQ 18
[ 0.124511] musb-hdrc musb-hdrc.1: dma type: dma-cppi41
[ 0.124694] MUSB1 controller’s USBSS revision = 4ea20800
[ 0.125152] musb-hdrc musb-hdrc.1: MUSB HDRC host driver
[ 0.125274] musb-hdrc musb-hdrc.1: new USB bus registered, assigned bus number 1
[ 0.125427] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
[ 0.125457] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[ 0.125488] usb usb1: Product: MUSB HDRC host driver
[ 0.125488] usb usb1: Manufacturer: Linux 3.2.33-psp26 musb-hcd
[ 0.125518] usb usb1: SerialNumber: musb-hdrc.1
[ 0.126281] hub 1-0:1.0: USB hub found
[ 0.126312] hub 1-0:1.0: 1 port detected
[ 0.126861] musb-hdrc musb-hdrc.1: USB Host mode controller at d081e800 using DMA, IRQ 19
[ 0.127380] NET: Registered protocol family 2
[ 0.127716] IP route cache hash table entries: 2048 (order: 1, 8192 bytes)
[ 0.128692] TCP established hash table entries: 8192 (order: 4, 65536 bytes)
[ 0.128906] TCP bind hash table entries: 8192 (order: 3, 32768 bytes)
[ 0.129028] TCP: Hash tables configured (established 8192 bind 8192)
[ 0.129058] TCP reno registered
[ 0.129058] UDP hash table entries: 256 (order: 0, 4096 bytes)
[ 0.129089] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[ 0.129486] NET: Registered protocol family 1
[ 0.129913] RPC: Registered named UNIX socket transport module.
[ 0.129943] RPC: Registered udp transport module.
[ 0.129943] RPC: Registered tcp transport module.
[ 0.129974] RPC: Registered tcp NFSv4.1 backchannel transport module.
[ 0.130249] Trying to unpack rootfs image as initramfs…
[ 0.661804] usb 1-1: new low-speed USB device number 2 using musb-hdrc
[ 0.830108] usb 1-1: New USB device found, idVendor=05af, idProduct=0003
[ 0.830139] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 0.830169] usb 1-1: Product: USB Keyboard
[ 0.830169] usb 1-1: Manufacturer: SUNREX
[ 1.434265] Freeing initrd memory: 9960K
[ 1.436401] audit: initializing netlink socket (disabled)
[ 1.436492] type=2000 audit(1.420:1): initialized
[ 1.631622] VFS: Disk quotas dquot_6.5.2
[ 1.631774] Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
[ 1.633605] nfs4filelayout_init: NFSv4 File Layout Driver Registering…
[ 1.633697] fuse init (API version 7.17)
[ 1.634429] Btrfs loaded
[ 1.634490] msgmni has been set to 490
[ 1.635803] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 252)
[ 1.635955] io scheduler noop registered
[ 1.635955] io scheduler deadline registered
[ 1.636047] io scheduler cfq registered (default)
[ 1.637298] Serial: 8250/16550 driver, 4 ports, IRQ sharing enabled
[ 1.638641] omap_uart.0: ttyO0 at MMIO 0x44e09000 (irq = 72) is a OMAP UART0
[ 2.377960] console [ttyO0] enabled
[ 2.382202] omap_uart.1: ttyO1 at MMIO 0x48022000 (irq = 73) is a OMAP UART1
[ 2.390014] omap_uart.2: ttyO2 at MMIO 0x48024000 (irq = 74) is a OMAP UART2
[ 2.397888] omap_uart.3: ttyO3 at MMIO 0x481a6000 (irq = 44) is a OMAP UART3
[ 2.405761] omap_uart.4: ttyO4 at MMIO 0x481a8000 (irq = 45) is a OMAP UART4
[ 2.413604] omap_uart.5: ttyO5 at MMIO 0x481aa000 (irq = 46) is a OMAP UART5
[ 2.429748] brd: module loaded
[ 2.437500] loop: module loaded
[ 2.440917] at24 1-0051: 32768 byte 24c256 EEPROM, writable, 64 bytes/write
[ 2.500976] No daughter card found
[ 2.504608] at24 1-0050: 32768 byte 24c256 EEPROM, writable, 64 bytes/write
[ 2.519927] Board config.name: A335BONE00A40312BB000644
[ 2.525482] Board name: A335BONE
[ 2.528869] Board version: 00A4
[ 2.532196] The board is a AM335x Beaglebone.
[ 2.537475] tps65217 1-0024: TPS65217 ID 0x7 version 1.0
[ 2.544982] print_constraints: DCDC1: 900 <–> 1800 mV at 1800 mV
[ 2.553497] print_constraints: DCDC2: 900 <–> 3300 mV at 1200 mV
[ 2.561920] print_constraints: DCDC3: 900 <–> 1500 mV at 1100 mV
[ 2.570312] print_constraints: LDO1: 1000 <–> 3300 mV at 1800 mV
[ 2.578765] print_constraints: LDO2: 900 <–> 3300 mV at 3300 mV
[ 2.587127] print_constraints: LDO3: 1800 <–> 3300 mV at 3250 mV
[ 2.595581] print_constraints: LDO4: 1800 <–> 3300 mV at 3300 mV
[ 2.602813] omap_i2c.3: alias fck already exists
[ 2.608093] omap_i2c omap_i2c.3: bus 3 rev2.4.0 at 100 kHz
[ 2.618499] at24 3-0054: 32768 byte 24c256 EEPROM, writable, 64 bytes/write
[ 2.680969] BeagleBone cape EEPROM: could not read eeprom at address 0x54
[ 2.688171] at24 3-0055: 32768 byte 24c256 EEPROM, writable, 64 bytes/write
[ 2.750976] BeagleBone cape EEPROM: could not read eeprom at address 0x55
[ 2.758178] at24 3-0056: 32768 byte 24c256 EEPROM, writable, 64 bytes/write
[ 2.820953] BeagleBone cape EEPROM: could not read eeprom at address 0x56
[ 2.828186] at24 3-0057: 32768 byte 24c256 EEPROM, writable, 64 bytes/write
[ 2.890960] BeagleBone cape EEPROM: could not read eeprom at address 0x57
[ 2.898101] BeagleBone cape: initializing mmc
[ 2.902740] omap_hsmmc.0: alias fck already exists
[ 2.908264] BeagleBone cape: exporting ADC pins to sysfs
[ 2.914215] Beaglebone: initializing onboard LEDs
[ 2.919189] BeagleBone cape: exporting SPI pins as spidev
[ 2.925445] BeagleBone cape: initializing w1-gpio
[ 2.930572] w1-gpio connected to P8_6
[ 2.935485] CAN device driver interface
[ 2.939544] CAN bus driver for Bosch D_CAN controller 1.0
[ 2.990997] davinci_mdio davinci_mdio.0: davinci mdio revision 1.6
[ 2.997528] davinci_mdio davinci_mdio.0: detected phy mask fffffffe
[ 3.011566] davinci_mdio.0: probed
[ 3.015167] davinci_mdio davinci_mdio.0: phy[0]: device 0:00, driver SMSC LAN8710/LAN8720
[ 3.024047] usbcore: registered new interface driver cdc_ether
[ 3.030273] usbcore: registered new interface driver rndis_host
[ 3.036590] cdc_ncm: 04-Aug-2011
[ 3.040069] usbcore: registered new interface driver cdc_ncm
[ 3.046173] Initializing USB Mass Storage driver…
[ 3.051544] usbcore: registered new interface driver usb-storage
[ 3.057861] USB Mass Storage support registered.
[ 3.062927] usbcore: registered new interface driver libusual
[ 3.069091] gadget: using random self ethernet address
[ 3.074645] gadget: using random host ethernet address
[ 3.081237] usb0: MAC 26:53:e6:d0:17:30
[ 3.085266] usb0: HOST MAC 6a:a1:1b:72:58:93
[ 3.089843] gadget: Ethernet Gadget, version: Memorial Day 2008
[ 3.096221] gadget: g_ether ready
[ 3.099822] musb-hdrc musb-hdrc.0: MUSB HDRC host driver
[ 3.105529] musb-hdrc musb-hdrc.0: new USB bus registered, assigned bus number 2
[ 3.113494] usb usb2: New USB device found, idVendor=1d6b, idProduct=0002
[ 3.120666] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[ 3.128295] usb usb2: Product: MUSB HDRC host driver
[ 3.133544] usb usb2: Manufacturer: Linux 3.2.33-psp26 musb-hcd
[ 3.139801] usb usb2: SerialNumber: musb-hdrc.0
[ 3.145599] hub 2-0:1.0: USB hub found
[ 3.149597] hub 2-0:1.0: 1 port detected
[ 3.154785] mousedev: PS/2 mouse device common for all mice
[ 3.161895] omap_rtc omap_rtc: rtc core: registered omap_rtc as rtc0
[ 3.168609] omap_rtc: already running
[ 3.172607] i2c /dev entries driver
[ 3.176788] Linux media interface: v0.10
[ 3.181121] lirc_dev: IR Remote Control driver registered, major 249
[ 3.187896] Driver for 1-wire Dallas network protocol.
[ 3.194854] OMAP Watchdog Timer Rev 0x01: initial timeout 60 sec
[ 3.206878] cpuidle: using governor ladder
[ 3.211395] cpuidle: using governor menu
[ 3.223388] input: SUNREX USB Keyboard as /devices/platform/omap/musb-ti81xx/musb-hdrc.1/usb1/1-1/1-1:1.0/input/input0
[ 3.235443] generic-usb 0003:05AF:0003.0001: input,hidraw0: USB HID v1.10 Keyboard [SUNREX USB Keyboard] on usb-musb-hdrc.1-1/input0
[ 3.254180] input: SUNREX USB Keyboard as /devices/platform/omap/musb-ti81xx/musb-hdrc.1/usb1/1-1/1-1:1.1/input/input1
[ 3.267913] generic-usb 0003:05AF:0003.0002: input,hidraw1: USB HID v1.10 Device [SUNREX USB Keyboard] on usb-musb-hdrc.1-1/input1
[ 3.280334] usbcore: registered new interface driver usbhid
[ 3.286193] usbhid: USB HID core driver
[ 3.291290] usbcore: registered new interface driver snd-usb-6fire
[ 3.298370] ALSA device list:
[ 3.301513] No soundcards found.
[ 3.306243] TCP cubic registered
[ 3.309814] NET: Registered protocol family 10
[ 3.317810] NET: Registered protocol family 17
[ 3.322692] can: controller area network core (rev 20090105 abi 8)
[ 3.329284] NET: Registered protocol family 29
[ 3.333984] can: raw protocol (rev 20090105)
[ 3.338470] Registering the dns_resolver key type
[ 3.343536] VFP support v0.3: implementor 41 architecture 3 part 30 variant c rev 3
[ 3.351593] ThumbEE CPU extension supported.
[ 3.356140] mux: Failed to setup hwmod io irq -22
[ 3.361877] Power Management for AM33XX family
[ 3.371643] registered taskstats version 1
[ 3.376281] Detected MACID=d4:94:a1:93:66:ca
[ 3.383666] omap_rtc omap_rtc: setting system clock to 2000-01-01 01:42:53 UTC (946690973)
[ 3.393371] Freeing init memory: 248K
[ 3.484191] mmc0: host does not support reading read-only switch. assuming write-enable.
[ 3.500396] mmc0: new high speed SDHC card at address 0007
[ 3.507080] gadget: high-speed config #1: CDC Ethernet (ECM)
[ 3.521118] mmcblk0: mmc0:0007 SD08G 7.39 GiB
[ 3.542846] mmcblk0: p1
Starting system log daemon: syslogd, klogd.
┌───────────────────────┤ [!!] Select a language ├────────────────────────┐
│ │
│ Choose the language to be used for the installation process. The │
│ selected language will also be the default language for the installed │
│ system. │
│ │
│ Language: │
│ │
│ C │
│ English │
│ │
│ │
│ │
└─────────────────────────────────────────────────────────────────────────┘

moves; selects; activates buttons

On OpenSuse 12.2 the configuration section displays well. But no keyboard
inputs will be accepted ...

Correct...

When running in serial mode.. The debian-installer only accepts inputs
from the serial terminal device, NOT anything hooked up to the
device...

So, in your case... Yes the usb keyboard connected to the bone will be
ignored... Now if you were to connect a "dvi cape" to the beaglebone
and run the netinstall with the newer v3.8-rc6 kernel in video mode
the usb keyboard events would accepted.. :wink:

[ 0.661804] usb 1-1: new low-speed USB device number 2 using musb-hdrc
[ 0.830108] usb 1-1: New USB device found, idVendor=05af, idProduct=0003
[ 0.830139] usb 1-1: New USB device strings: Mfr=1, Product=2,
SerialNumber=0
[ 0.830169] usb 1-1: Product: USB Keyboard
[ 0.830169] usb 1-1: Manufacturer: SUNREX

Regards,

I’ve had the same issue and resorted to asking a few questions on IRC. I worked around the issue by using a Debian “Wheezy” VM to perform tha install. On a side note, it is rather simple to support the USB ethernet gadget on Debian. Here is how I dunnit and here is the command line to get “Wheezy” instead of “Squeeze” installed on the BeagleBone.

By default the Debian installer uses something called newt to present the ASCII like graphical installation screens. It is possible to force the Debian installer to use plain text mode. The installer required the boot parameter “DEBIAN_FRONTEND=text” and it will do plain text. This parameter needs to be specified in “uEnv.txt” on the SD card before booting the installer. If I remember correctly, I appended it to the “mmcargs=” line. I do have to say the text only option requires some getting used to. It works fine with Mac OS X. But after accidentally making the wrong choices too many times I found the traditional text based install using a “Wheezy” VM to much less of an effort.

Adi

Hi Robert,
I am not using the dvi cape :wink: I attached a normal Keyboard.

So I will give the option --serial-mode a chance.
Thank you
Kind regards,
Gerrit

Well that is the default mode when using "--uboot bone"...

Down the road when we really switch to v3.8.x it'll be:

"--dtb am335x-bone-serial"
(or)
"--dtb am335x-bone-video"

which will replace "--uboot bone"

Regards,

And the Hero is … ADI…
Now it works! On Mac OS X! Thanks a lot!
:slight_smile:

Hi Robert, Hi Adi,

Debian is now on my beaglebone. And it is up and running since yesterday.
WLAN is a matter of minutes.

Many thanks to you both for the very fast support.

Kind regards,
Gerrit