strange error when running simple *.js filesetting a (GPIO) to output using beaglebone black Rev C.

Hello! How’s everything?

I encountered strange error when running simple *.js file
setting a pin (GPIO) to output using beaglebone black Rev C, which I received this August.

I even reinstalled bonescript using
“npm install -g bonescript”
but still encounter the same error message.

led = “P9_11”, “9_12” worked
led = “P8_39”, “P8_40”, “P8_41”, and many other pins
does not work with error message listed below
following “simpleDigitalOut.js”:


var b = require(’/usr/local/lib/node_modules/bonescript’);

var led = “P8_41”;
b.pinMode(led, b.OUTPUT);

console.log(“end of program”);

root@beaglebone:/var/lib/cloud9/myProg# node simpleDigitalOut.js

if(slot[0]) {
TypeError: Cannot read property ‘0’ of null
at Object.exports.load_dt (/usr/local/lib/node_modules/bonescript/my.js:57:20)
at Object.exports.create_dt (/usr/local/lib/node_modules/bonescript/my.js:123:33)
at Object.exports.setPinMode (/usr/local/lib/node_modules/bonescript/hw_capemgr.js:83:12)
at Object.f.pinMode (/usr/local/lib/node_modules/bonescript/index.js:160:15)
at Object. (/var/lib/cloud9/myProg/simpleDigitalOut.js:4:3)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:312:12)
at Function.Module.runMain (module.js:497:10)

I googled but cannot find a solution to this problem.

It would be a great help if you can guide me through it.
your advice is very much appreciated.

Many thanks,
Fung Yang

Hi, I am guessing here only.
These GPIO are by default reserved for HDMI connection (look-up PIN assignment for beagle bone black). I think you might need to disable HDMI.
See below my `/boot/uEnv.txt to disable HDMI

cat /boot/uEnv.txt




cmdline=quiet init=/lib/systemd/systemd




##Disable HDMI/eMMC


##Disable HDMI


##Disable eMMC


##Audio Cape (needs HDMI Audio disabled)



##enable BBB: eMMC Flasher: