Switching to Jessie from Wheezy.

@Robert – How do I switch to Jessie?

(I notice gcc-4.9 is a happening thing for your latest jessie images and suspect that jessie is further along in it’s support for systemd, but your your latest console images are wheezy only.)

“apt-get dist-upgrade” didn’t work. I thought about trying a search and replace wheezy/jessie in apt-sources but there must be a better way.

Thanks in advance / IOU beer.

Cheers.

That was rude of me; the answer was pretty much low hanging fruit, and I didn’t have the sense to look.

However I did have one glitch and I don’t know that it’s not important…

This is what I did:

# apt-get update
# apt-get upgrade
# cp /etc/apt/sources.list{,.bak}
# sed -i -e 's/wheezy/jessie/g' /etc/apt/sources.list
# apt-get update

At this point it became apparent that this line from my new /etc/apt/sources file was not working:

deb [arch=armhf] [http://debian.beagleboard.org/packages](http://debian.beagleboard.org/packages) jessie-bbb main

I continued anyway with:

# apt-get update
# reboot

Things seem to have worked out.
But if someone sees a problem with that one repo not translating over to "jessie" please let me know
(otherwise I'll just comment it out to get rid of the warnings)

Thanks.

# apt-get update

# apt-get update

# reboot

..that's meant to be: "apt-get dist-update"

damn.. that's "apt-get dist-upgrade"

apt-get update

reboot

…that’s meant to be: “apt-get dist-update”

damn… that’s “apt-get dist-upgrade”

This syntax is pretty reliable:

http://elinux.org/BeagleBoardDebian#Upgrading_from_Debian_6_.28Squeeze.29_to_Debian_7_.28Wheezy.29

You can drop the bb.org repo and add my repos.rcn-ee.net to get those specific packages that where in the bb.org repo…