Sync with ntp

Hi, my Beaglebone Blue does not sync with NTP. I followed the instructions at https://stackoverflow.com/questions/46148481/set-the-date-in-begalebone-black-using-ntp-debian-8-9 but just as in the case of the original poster, the BB does not sync after reboot. Can anything be done with that? RPi does sync with NTP out-of-the-box on the same Wifi.

$ service ntp status
● ntp.service - LSB: Start NTP daemon
Loaded: loaded (/etc/init.d/ntp; generated; vendor preset: enabled)
Active: active (running) since Thu 2016-11-03 18:16:53 CET; 20min ago
Docs: man:systemd-sysv-generator(8)
Process: 547 ExecStart=/etc/init.d/ntp start (code=exited, status=0/SUCCESS)
Tasks: 2 (limit: 4915)
CGroup: /system.slice/ntp.service
└─647 /usr/sbin/ntpd -p /var/run/ntpd.pid -g -u 109:116

Nov 03 18:35:29 beaglebone ntpd[647]: Soliciting pool server 94.177.239.114
Nov 03 18:35:30 beaglebone ntpd[647]: Soliciting pool server 94.23.2.80
Nov 03 18:36:26 beaglebone ntpd[647]: Soliciting pool server 163.172.61.210
Nov 03 18:36:29 beaglebone ntpd[647]: Soliciting pool server 51.15.182.163
Nov 03 18:36:33 beaglebone ntpd[647]: Soliciting pool server 194.57.169.1
Nov 03 18:36:34 beaglebone ntpd[647]: Soliciting pool server 195.154.174.209
Nov 03 18:37:30 beaglebone ntpd[647]: Soliciting pool server 37.59.27.22
Nov 03 18:37:36 beaglebone ntpd[647]: Soliciting pool server 151.80.19.218
Nov 03 18:37:38 beaglebone ntpd[647]: Soliciting pool server 95.81.173.155
Nov 03 18:37:38 beaglebone ntpd[647]: Soliciting pool server 185.123.84.51
$ date
Thu Nov 3 18:38:14 CET 2016

By default we ship with systemd-timesyncd enabled and active.. The
ntp package was probally blocked by that..

Regards,

Thus, by default BB is expected to synchronize? It it did not do this, this may mean that some ports are blocked?