systemd issues

I'm trying to get ssh and ntp started at boot time but systemd doesn't want
to cooperate. I'm running Linux Kernel V3.2.23 built with Angstrom's
console-image. Here is what I'm doing:

If I start ssh manually using "systemctl start dropbear.socket", a socket is
established and when I connect using an ssh client, dropbear.service is
started. However, when I want to start ssh at boot time, I issue the
following command:

"systemctl enable dropbear.socket", but after I login, "systemctl status
dropbear.socket" shows that the service hasn't been started (inactive) and I
have to start the service manually. When I enable the dropbear.socket, two
links are created, one for dropbear.socket and the other for
dropbear.service, so this should work. Anyone know why this doesn't work?

Also, I'm trying to set the clock on the Beagle-xM. I do this using NTP
services. If I set the time manually using the command:

"systemctl start ntpdate.service", the clock synchronizes in about 6 seconds
after a fresh boot. This command is actually using ntp -g -x -q to set the
time quickly and exit. If I do a

"systemctl enable ntpdate.service" and then reboot, when I try to login, it
takes several minutes to receive a user prompt. If I disable the ntpdate
service, the login has no delay. Any idea why ntpdate takes so long to
synchronize at boot time?

Regards,

John