Touch on LCD Chipsee (BBB-EXP-C) stopped respond

Hi,
I have BeagleBoneBlack(revC) and this capacitive touchscreen from Chipsee: https://www.logicsupply.com/bbb-exp-c/.

When I tried check temperature of display (which is too high I think) with my palm, I simulated stop of touch responding. Then I tried touch on display with my fingers and palm randomly, but I had to touch display many times to accomplish responding of touch again.

I attach some logs from /var/log.

Some additional information from Debian Jessie:

uname -a Linux beaglebone 4.4.62-ti-r103 #1 SMP Fri May 12 22:14:44 UTC 2017 armv7l GNU/Linux

xinput --list ? Virtual core pointer id=2 [master pointer (3)] ? ? Virtual core XTEST pointer id=4 [slave pointer (2)] ? ? EP0790M09 id=8 [slave pointer (2)] ? Virtual core keyboard id=3 [master keyboard (2)] ? Virtual core XTEST keyboard id=5 [slave keyboard (3)] ? gpio_keys id=6 [slave keyboard (3)] ? tps65217_pwr_but id=7 [slave keyboard (3)]

Problem is that our customer use JAVA application on Beagleaboard revC with Chipsee display which must work nonstop.

There are some possibilities of solutions, I hope:
1.) touchscreen driver fix
2.) detection of not touch responding in JAVA application and restart of display

With this command I can restart display:

sudo /etc/init.d/lightdm restart
But it lasts 40 seconds. Maybe there is some command for faster reset which can I run from JAVA application as Runtime.getRuntime().exec);

lightdm.log (3.02 KB)

x-0.log (2.4 KB)

x-0-greeter.log (543 Bytes)

Xorg.0.log (65 KB)

So, now I have figured I can reproduce same problem with rezistive display from 4D Systems (BBB revC and Debian Wheezy(not Jessie)), when I touch display with my palm.

But command

sudo /etc/init.d/lightdm restart

doesn’t help at all. Display reboot with java application autostart lasted 20 seconds, but touch didn’t still respond. When I touched this resistive display, I cannot still accomplish to start touch again after many tries with palm and finger touches.

It’s possible that your palm deposits water or body oils and confuses the resistive sensors. Can you try wiping the display with a paper towel,perhaps sligtly moist with alcohol?

Thanks for your answer, but what about capacitive Chipsee touchscreen behaviour?
I think the whole problem is related with multitouch, but I don’t know how correctly set some touchscreen options in OS Debian.

Dňa utorok, 8. augusta 2017 15:20:02 UTC+2 Przemek Klosowski napísal(-a):

The same problem appears with touchpad or even with mouse.
Discussion here: https://askubuntu.com/questions/528293/is-there-a-way-to-restart-the-touchpad-driver

Using these commands

xinput disable EP0790M09 xinput enable EP0790M09

input driver for “touch” functionality restarted and then touchscreen started respond again.

But, it will be useful, if there is solution with preventing of this touch problem.