Touchscreen and ACEcad tablet inputs

Hello, I am having an issue with getting two different touch inputs to
work at the same time on the beagle board.

First off, I am running the Angstrom Demo Image on my beagle board,
and I am using an externally powered 4 port USB hub. I also have a
USB mouse and keyboard, but I have the same problems even if i dont
plug those in at all.

I am using a USB ACEcad DigiMemo tablet, and a USB HanTouch touch
screen. The ACEcad worked right away after pluging in the USB (no
drivers, or special file editing required). The HanTouch required me
to go through the Xenarc touch screen setup <http://www.elinux.org/
Xenarc_USB_touchscreen_for_Beagleboard/OMAP3_EVM>. Both work just
fine alone, but if both are plugged in at the same time (or one is
pluged in after the other is up and running) I get USB errors, and the
second device added does not work.

If I add the touch screen second, the serial terminal printout for the
beagle board reports the recognition of the device, but then does
nothing else, and the touch screen wont work (however, the mouse,
keyboard and ACEcad still work fine). Sometimes it also gives a
message of:
hub 2-1:1.0: hub_port_status failed (err = -110)

If I add the ACEcad tablet second, the serial terminal printout for
the beagle board reports the recognition of the device, (and ive even
seen it physically respond and move the cursor for a second or two),
but then gives a message of:
WARNING: at drivers/usb/musb/musb_host.c:128 musb_h_tx_flush_fifo
+0x94/0xd4()
Could not flush host TX13 fifo: csr: 0003
(however, the mouse, keyboard and touch screen still work fine).

I have tried adding to the xorg.conf file that I edited in the touch
screen setup, but did not get any change. What I tried adding was as
follows (digitizer is what I called the ACEcad tablet):

Section "ServerLayout"
        InputDevice "touchscreen" "SendCoreEvents"
        InputDevice "digitizer" "SendCoreEvents"
        Identifier "Builtin Default
Layout"
        Screen "Builtin Default fbdev Screen 0"
EndSection

### Touch Configuration Beginning ###
Section "InputDevice"
            Identifier "touchscreen"
            Driver "evtouch"
            Option "Device" "/dev/input/evtouch_event"
            Option "DeviceName" "touchscreen"
            Option "MinX" "233"
            Option "MinY" "120"
            Option "MaxX" "4035"
            Option "MaxY" "3925"
            Option "ReportingMode" "Raw"
            Option "Emulate3Buttons"
            Option "Emulate3Timeout" "50"
            Option "SendCoreEvents" "On"
            Option "SwapX" "1"
EndSection
### Touch Configuration End ###

Section "InputDevice"
            Identifier "digitizer"
            Driver "acecad"
            Option "Device" "/dev/input/acecad_event"
            Option "DeviceName" "digitizer"
            Option "SendCoreEvents" "On"
EndSection

I also added a line to the 69-touchscreen.rules file to map the ACEcad
to acecad_event:

KERNEL=="event*", SUBSYSTEM=="input", SYSFS{idVendor}=="0eef", SYSFS
{idProduct}=="0001", SYMLINK+="input/evtouch_event"
KERNEL=="event*", SUBSYSTEM=="input", SYSFS{idVendor}=="0460", SYSFS
{idProduct}=="1002", SYMLINK+="input/acecad_event"

Any ideas on why both inputs wont work at the same time, and how I can
fix that? Thank you in advance for any help.

       Kevin