trouble extracting all of OMAP3530_Graphics_SDK

When I run ./OMAP35x_Graphics_SDK_setuplinux_3_00_00_06.bin [4]
I only seem to get some of the contents of the package, namely:
gfx_debug
Makefile
OMAP35x_Graphics_SDK_GettingStartedGuide.pdf
readme.pdf
Rules.make

The OMAP bin was run using DSL via vmwareplayer on XP. It was run from
and extracted onto a thumbdrive.

This is what is supposed to be there: [2]
1.1 What’s in the SDK Package?
The OMAP35x Graphics SDK package consists of the following folders
• GFX_Linux_SDK
• GFX_Linux_KM
• gfx_dbg
• gfx_rel
• targetfs
• patches
• Getting Started Guide (This document)
• Rules.make
• Makefile
• readme.pdf

I was hoping to simply get the content I need and install manually on
my revC3 Angstrom 2.6.29. Is it possible to simply get the files
needed and not have to bitbake (as described in [3]) or cross compile?

I was hoping to simply get to the step of installing the libgles-
omap3*armv7a.ipk packages or manually installing the contents od the
directory "gfx_rel" on the beagleboard and start developing without
the use of a toolchain.

I have seen mention of pvrsrvinit [1] but the TI pdf [2] does not seem
to reference it.
Does anyone know if this is still needed or what it does?

[1] http://elinux.org/BeagleBoardDebian#SGX_Video_Acceleration
[2] http://www.beagleboard.org/~arago/OMAP35x_Graphics_SDK_GettingStartedGuide.pdf
[3] http://code.google.com/p/beagleboard/wiki/HowtoUseSGXunderAngstrom
[4] http://software-dl.ti.com/dsps/dsps_registered_sw/sdo_sb/targetcontent//dvsdk/oslinux_dvsdk/v3_00_3530/index.html

My copy works, what's the md5sum on yours?

$ md5sum -b OMAP35x_Graphics_SDK_setuplinux_3_00_00_06.bin
6711270571f7c5567a0951d97e91519c *OMAP35x_Graphics_SDK_setuplinux_3_00_00_06.bin

$ md5sum OMAP35x_Graphics_SDK_setuplinux_3_00_00_06.bin
6711270571f7c5567a0951d97e91519c
*OMAP35x_Graphics_SDK_setuplinux_3_00_00_06.bin

I tried on damn small linux under vmware.
I'll try to hunt down another linux PC.
It would not execute under ubuntu and cygwin.
I wonder why it is is only available as part of the TI SDK.

I get the same checksum, thanks for the doeble check.

I was able to extract it on a redhat box and all went well.
I wonder why TI does not distribute just the core components instead
of or in addition to, that big SDK.

So, I got the ~/OMAP_SDK/GFX_Linux_SDK/OGLES/SDKPackage/Binaries/
CommonX11/Demos working
They all work great with the Xserver running.
I am getting all the same problems others describe per the ~/gfx-rel/
test executables.

Q1: where can you get the source for glest1est1 and xgles1test1?

I ran the OMAP...Graphics...SDK.bin with a redhat pc and copied the
OMAP_SDK/gfx_rel/*.so to usr/local/lib and the gl/egl include files
under the SDK to /usr/include/gl on the angstrom beagleboard.

The other missing link was getting the correct kernel modules to match
the release version of my 2.6.29r37 linux.
I actually had to use oer8.1 *.ko files from a debian build, couldn't
find the angstrom r37 *.ko files

when I run /etc/init.d/gpe-dm stop, I cannot get ~/OMAP_SDK/
GFX_Linux_SDK/OGLES/SDKPackage/Binaries/CommonRaw/Demos to work.
The application error is "failed to create window surface" and
the dmesg errror is: "[ 630.057861] PVR_K:(Error):
PVRSRVCreateDCSwapChainKM: Failed to create 3rd party SwapChain [912, /
mnt/debian/omap3-sgx-modules-1.3.13.1397/services4/srvkm/common/
deviceclass.c]"

I tried changing the vram bootargs and had success wit hthe following
boot args:
console=ttyS2,115200n8 console=tty0 root=/dev/mmcblk0p2 rootwait
nohz=off omapfb.mode=dvi:1024x768MR-16@60 vram=24M omapfb.vram=0:8M,
1:8M,2:8M

I get the same errors when running the following code:
gcc egltest.c -lGLES_CM

Q2: I could only get a context to return when specifying 565, Does
this mean that you cannot perform alpha channel blend operations?

<code>
#include <gl/egl.h>

#include <stdlib.h>
#include <stdio.h>
#include <math.h>

static EGLint attrib_list [] = {
        EGL_RED_SIZE, 5, /* 0 */
        EGL_GREEN_SIZE, 6, /* 2 */
        EGL_BLUE_SIZE, 5, /* 4 */
        EGL_ALPHA_SIZE, 0, /* 6 */
        EGL_STENCIL_SIZE, 0, /* 8 */
        EGL_DEPTH_SIZE, 16, /* 10 */
        EGL_NONE
};

EGLDisplay eglDisplay;
EGLSurface eglSurface;

void eglDraw();

void eglInit()
{
  EGLint versMajor;
  EGLint versMinor;
  EGLBoolean result;

  eglDisplay = eglGetDisplay(0);

  result = eglInitialize(eglDisplay, &versMajor, &versMinor);
  if (result)
  {
    EGLConfig config;
    EGLint num_configs;
    EGLContext eglContext;

    fprintf(stderr, "EGL version %d.%d\n", versMajor, versMinor);

    eglChooseConfig(eglDisplay, attrib_list, &config, 1,
&num_configs);
    fprintf(stderr, "eglChooseConfig returned %d configurations\n",
        num_configs);
    if (num_configs == 0)
    {
      exit(0);
    }

    eglContext = eglCreateContext(eglDisplay, config, NULL, NULL);
    if (eglContext == EGL_NO_CONTEXT)
    {
      fprintf(stderr, "failed to allocate context\n");
      exit(0);
    }

    eglSurface = eglCreateWindowSurface(eglDisplay, config, 0, NULL);
    if (eglSurface == EGL_NO_SURFACE)
    {
      fprintf(stderr, "failed to create window surface\n");
      exit(0);
    }

    eglMakeCurrent(eglDisplay, eglSurface, eglSurface, eglContext);
  }
  else
    fprintf(stderr, "EGL init failed\n");

eglSwapInterval(eglDisplay, 0);

  glFrontFace(GL_CCW);
  glShadeModel(GL_SMOOTH);
  glEnable(GL_CULL_FACE);

  glDepthFunc(GL_LEQUAL);
  glEnable(GL_DEPTH_TEST);
  //glDepthMask(GL_TRUE);

  //glEnable(GL_NORMALIZE);
  //glEnable(GL_COLOR_MATERIAL);
  //glEnable(GL_TEXTURE_2D);
  glDisable(GL_STENCIL_TEST);
  glDisable(GL_ALPHA_TEST);
  glDisable(GL_SCISSOR_TEST);

{
GLfloat fSizes[2];
glGetFloatv(GL_SMOOTH_POINT_SIZE_RANGE, fSizes);
fprintf(stderr, "%f %f\n", fSizes[0], fSizes[1]);
}

  glClearColor(0.0f, 0.0f, 0.0f, 1.0f);

// loop through all modules and init
  //MapsInit();
  //TargetInit();

fprintf(stderr, "egl initialized\n");

}

void eglDraw()
{
  static int W = 0;
  static GLfloat angle = 0.0f;
  float s;

  glClear(GL_COLOR_BUFFER_BIT | GL_DEPTH_BUFFER_BIT |
GL_STENCIL_BUFFER_BIT);
#ifndef __pc__
  glClearDepthf(1.0f);
#endif

  // set 3d projection
  {
#ifdef __psp__
    float ar = 272.0/480.0;
#else
    float ar = 480.0/320.0;
#endif
    s = 1.0 - 1.0 * cos(W/100.0);
    W++;
    glMatrixMode(GL_PROJECTION);
    glLoadIdentity();
    glOrthof(-1, 1, -ar, ar, 0, 5);
    glTranslatef(0,0,-3);
    glScalef(s, s, s);
  }
  {
    glMatrixMode(GL_MODELVIEW);
    glLoadIdentity();
    glRotatef(angle * 0.79f, 1.0f, 0.0f, 0.0f);
    glRotatef(angle * 0.98f, 0.0f, 1.0f, 0.0f);
    glRotatef(angle * 1.32f, 0.0f, 0.0f, 1.0f);
    angle += 0.1;
  }

  // draw all 3d modules
  //MapsDraw(0);
  //TargetDraw(0);

  // set 2d projection
  // draw all 2d modules

  // swap frame buffers
  //if (!eglSwapBuffers(eglGetCurrentDisplay(), eglGetCurrentSurface
(EGL_DRAW)))
    //printf("swap error: %04x\n", eglGetError());
  eglSwapBuffers(eglDisplay, eglSurface);
}

void eglFree()
{
  // free all modules
  //MapsFree();

  eglMakeCurrent(eglGetCurrentDisplay(), EGL_NO_SURFACE,
EGL_NO_SURFACE,
      EGL_NO_CONTEXT);
  eglTerminate(eglGetCurrentDisplay());

#ifdef __psp__
  eglMakeCurrent(eglDisplay, EGL_NO_SURFACE, EGL_NO_SURFACE,
EGL_NO_CONTEXT);
  eglTerminate(eglDisplay);
#endif
}

int main()
{
  eglInit();
  while (1)
  {
    eglDraw();
  }
  return(0);
}

</code>

When running raw egl executables I get "no flipping" written to the
log every frame.
I linked against the libraries in the release directory and not the
debug directory.
Does anybody know why and how to remedy?
Does anybody know how to suppress the extra log messages?