Trouble with GPIOs

I've been trying to get input and output GPIOs to work following Derek Molloy's videos and book. I'm using Debian 7/3.8.13-bone68. Pin 36, by default, is configured as an input with pullup enabled. When I measure that pin with a DMM, it's near 3.3 V. But when I try to read the value via sysfs, I always get 0.

Here's how things look for pin 36, P8_07:

# cat /sys/kernel/debug/pinctrl/44e10800.pinmux/pins | grep 890
pin 36 (44e10890) 00000037 pinctrl-single

# ls /sys/class/gpio
export gpio36 gpiochip0 gpiochip32 gpiochip64 gpiochip96 unexport

# cat /sys/class/gpio/gpio36/direction

# cat /sys/class/gpio/gpio36/value

# cat /sys/devices/bone_capemgr.9/slots
0: 54:PF---
1: 55:PF---
2: 56:PF---
3: 57:PF---
4: ff:P-O-L Bone-LT-eMMC-2G,00A0,Texas Instrument,BB-BONE-EMMC-2G
5: ff:P-O-L Bone-Black-HDMI,00A0,Texas Instrument,BB-BONELT-HDMI

Similarly I tried setting the direction to "out", and tried setting the value, but it had no effect on the output voltage.

Am I missing a step? I followed the instructions here:

I also tried setting up the overlay as directed later in the example, but it made no difference.

I'd really appreciate any help!

Okay, I installed the 2014-12-11 bone-console test image onto an SD card, booted from that, and tried again, with the same result. I guess I should go back to the version used by Derek Molloy.

Praise Jibbers, I'm an idiot. I misunderstood all the admonitions that "GPIO number" wasn't the same as "pin number." I thought "GPIO Number" was some TI reference, and "pin number" was how Linux referred to the pin. But in fact, Linux (in its infinite wisdom) uses two different labels for a pin, depending on what part of sysfs you're using. Awesome. Just awesome.

To be clear: The "pin number" (e.g. 36 for P8_07) is what's used in /sys/kernel/debug/pinctrl/44e10800.pinmux/pins. The "GPIO number" is what's used in /sys/class/gpio/...