Trying to compile pcsclite from debian

I am trying to compile pcsclite from svn://anonscm.debian.org/pcsclite.

procedure:
opkg install libusb-1.0-dev
svn co svn://anonscm.debian.org/pcsclite/trunk/
cd trunk
./bootstrap
./configure --enable-libusb --disable-libudev

apart from the fact that pod2man is not found so it can not make some documentation,

the build fails on:

LEX configfile.c
flex: fatal internal error, exec failed
make[3]: *** [configfile.c] Error 141

I read somewhere else that flex was not pointing to the right m4 executable, but I could not find anything about that.

Has anybody else experience with flex on Angstrom?

Did you find a solution?

I’m trying to use PCSCon a begalebone with angstron without any succes… any help will be apreciated!

Saludos

Did you find a solution?

No not yet. actually I am waiting until BeagleBoard officially will start using Debian instead of Angstrom (which they announced in january informally)

Why are you waiting?

https://groups.google.com/d/msg/beagleboard/D1ioNrzzXfQ/LdfJ2ccuiY4J

Regards,

Because of:

http://rcn-ee.net/deb/testing/2014-02-18/

No, the real reason was I am completely swamped with other work at the moment. I’ll get around to testing next week (I hope).


For more options, visit http://beagleboard.org/discuss

You received this message because you are subscribed to a topic in the Google Groups “BeagleBoard” group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/beagleboard/1kSAxE6GRiQ/unsubscribe.
To unsubscribe from this group and all its topics, send an email to beagleboard+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Johan Henselmans
johan.henselmans@gmail.com

you mean:

<cough> http://rcn-ee.net/deb/testing/2014-02-24/ </cough>

i need to get the email out..

Regards,

The problem is peculiar to some Angstrom images such as the v2012.12 one. Turns out /usr/bin/flex uses a hard-wired reference to the m4 executable where it lay on the machine where the Angstrom image was cross-compiled! (Thanks to Rob Clark for finding this out, http://gstreamer-devel.966125.n4.nabble.com/Installation-error-td969071.html) The ugly but simple fix is to create a symbolic link at the place flex looks for m4:

mkdir -p /build/v2012.12/build/tmp-angstrom_v2012_12-eglibc/sysroots/x86_64-linux/usr/bin

ln -s /usr/bin/m4 /build/v2012.12/build/tmp-angstrom_v2012_12-eglibc/sysroots/x86_64-linux/usr/bin/m4

You can find the path by using a hex editor to look at the /usr/bin/flex binary (search for /m4).

Or you can define the M4 environment variable before calling flex:

M4=/usr/bin/m4 flex .l