ttyO1-4 Not Working

I know this is a well discussed topic but none of the proposed solutions have worked for me.

Issue: Cannot get ttyO1/O2/etc to show up in dev folder.

I have modified the am335x-bone-ttyO1/O2 .dts, dtsi files per Robert’s suggestions, making sure include files are #included and statuses are “okay”.
Kernel config, “move O to S” is turned off-- but I’ve tried both on and off with no luck.

No luck. I’m about out of ideas at this point. I’m using a BB board with 3.14.53-ti-rt-r76 build.

The question I have is-- are their defined steps on how to check for issues on ttyO? Step 1, do this, step 2, do that. There’s just too many things to look at and too many things that can go wrong.

Any suggestions would be appreciated!!

You have it setup correctly: in am335x-boneblack.dts:

/* uart1: P9.24, P9.26 */
#include "am335x-ttyO1.dtsi"
#include "am335x-bone-ttyO1.dtsi"

Thus, either you updated the wrong "uname_r" directory or your not
booting the *.dtb you think you are..

Either way, "it" works in v3.14.x, but i'm done with that tree.. Use
v4.1.x + capemanager...