u-boot 2010 PATCHLEVEL=06 devkit8000

thx for the files! In ftp://ftp.denx.de/pub/u-boot/ I could not find
"U-Boot.bin" and under http://gitorious.org/devkit8000 I could not
find uImage - but I found it in your archive "4G1_FAT32.7z". It was a
little difficult for me to unpack the
"debootstrap_1.0.20ubuntu1~jaunty1_all.deb".
I have a SD-Card with partition Label1=FAT and Label2=ext2

Here are the setting:

I saw that there are so many problem.
:]

2010/7/23 Uwe <u.schoch@web.de>

thx for the files! In ftp://ftp.denx.de/pub/u-boot/ I could not find

Buid it yourself, or direct use the one I sent,
you need an ARM cross compiler.

“U-Boot.bin” and under http://gitorious.org/devkit8000 I could not

You also need the ARM cross compiler to build it yourself.
Please see http://elinux.org/BeagleBoard#Source
and http://elinux.org/ARMCompilers
(latest Sourcery G++ Lite for ARM GNU/Linux is recommanded)
Building it yourself can get the latest version of kernel,
and able to add more functionality.

find uImage - but I found it in your archive “4G1_FAT32.7z”. It was a
little difficult for me to unpack the
“debootstrap_1.0.20ubuntu1~jaunty1_all.deb”.

Why not use roostock to build rootfs by yourself
or directly untar the rootfs from http://rcn-ee.net/deb/rootfs/ ?
(10.04-minimal or 9.10.2-minimal is recommanded)

I have a SD-Card with partition Label1=FAT and Label2=ext2

Here are the setting:
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
+++++
Texas Instruments X-Loader 1.41
Starting on with MMC
Reading boot sector

200488 Bytes Read from MMC
Starting OS Bootloader from MMC…

U-Boot 2010.06 (Jun 30 2010 - 17:35:57)

OMAP3530-GP ES3.1, CPU-OPP2 L3-165MHz
OMAP3 DevKit8000 + LPDDR/NAND
I2C: ready
DRAM: 128 MiB
NAND: 128 MiB
In: serial
Out: serial
Err: serial
Die ID #186200040000000004032f6516016004
Net: dm9000
Hit any key to stop autoboot: 3 0
OMAP3 DevKit8000 # printenv

bootdelay=3
baudrate=115200
ethaddr=aa:bb:cc:dd:ee:ff
ipaddr=192.192.192.200
serverip=192.192.192.90
gatewayip=192.192.192.101
netmask=255.255.255.0
bootfile=“uImage”
splashimage=80000000
bootcmd=nand read.i 80300000 280000 210000;bootm 80300000
dieid#=186200040000000004032f6516016004
ethact=dm9000
lcdtype=7inch_LCD
bootargs=console=ttyS2,115200n8 root=/dev/ram initrd=0x81600000,40M
video=omapfb:mode:7inch_LCD

Wrong bootargs for this kernel.

bootcmd=mmc init;fatload mmc 0 80300000 uImage ;fatload mmc 0 81600000
ramdisk.gz;bootm 80300000

I guess you didn’t put any ramdisk.gz onto your SD’s first FAT partition.
Try to drop the “fatload mmc 0 81600000 ramdisk.gz;” option.

stdin=serial
stdout=serial
stderr=serial

Environment size: 553/131068 bytes
OMAP3 DevKit8000 #
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
+++++

When I boot, I see this:
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
+++++
Texas Instruments X-Loader 1.41
Starting on with MMC
Reading boot sector

200488 Bytes Read from MMC
Starting OS Bootloader from MMC…

U-Boot 2010.06 (Jun 30 2010 - 17:35:57)

With the newer U-Boot, you can use the boot.scr (boot script file)
instead of U-Boot environment partition on NAND to boot the kernel.
So, we can save different U-Boot setting for different environment
(each SD card or different kernel).

And, In order to read the boot.scr, you need to
erase the U-Boot Environment Partition.
(Mem address is got from your kernel boot log:
[ 15.967315] 0x000000260000-0x000000280000 : “U-Boot Env”)
Boot into U-Boot Environment, then type:

nand unlock 0x260000 0x20000

nand erase 0x260000 0x20000

reset

Then, you should try the bootargs Thomas Weber said
or mine:

$ vi boot.cmd

Thank you very much - now it works :slight_smile:

On the next step I tried to use a ubuntu-image from
http://elinux.org/BeagleBoardUbuntu#Lucid_10.04
There I got the next problem - booting with the same partition LABEL1
as above.

That means it didn't find what it was actually told to look for...

What are your u-boot bootargs? A full serial log from power on to
crash will show these settings used in the kernel log..

Regards,

“Waiting 2sec before mounting root device…”
Hmm…
Maybe you miss a “rootwait” in bootargs.
And replace rootdelay=2 with rootwait,
unless your kernel is too old.
I forgot which kernel version is beginning to support rootwait bootarg.

e.g. (my bootargs for DevKit8000)
setenv bootargs ‘console=ttyS2,115200n8 root=/dev/mmcblk0p2
rootfstype=ext3 rw rootwait vram=12M omapdss.def_disp=lcd omapfb.mode=lcd:800x480’

What’s your bootargs?

2010/7/29 Uwe <u.schoch@web.de>

Hi guys,
could you provide me also with a working recent u-boot,
I tried to compile one for devkit8000, but with mixed success.
(my kernel is recognized the mmcblk0p2 but can't mount it - i think
that
the u-boot is the problem here - I use bootargs like yours ...)
Thanks

Hi,
In boot args init param is missing.

if init file is in root directory, then init=/init

console=ttyS2,115200n8 noinitrd root=/dev/mmcblk0p2 omapdss.def_disp=tv omapfb.debug=y omapdss.debug=y omapfb.mode=“tv:ntsc” init=/init rootfstype=ext3 rw rootdelay=1 nohz=off

or

setenv bootargs mem=128M console=ttyS2,115200n8 root=/dev/mmcblk0p2 rw noinitrd
rootdelay=1

saminath