u-boot fix for phantom UART character hang at boot

Does anyone know if this version:

Linux beaglebone 3.8.13-bone70 #1 SMP Fri Jan 23 02:15:42 UTC 2015 armv7l GNU/Linux

already has the “u-boot fix for phantom UART character hang at boot”
My application cycles the power and re-boots often and occasionally it hangs up at boot with just the blue power LED on.

Thanks,
Kirk

That's the kernel... Completely independent of the bootloader...

SO... try again, but this time use your usb debug and find the bootloader
log..

Regards,

So it looks like I have get a serial cable??

Or is the bootloader log written to a file somewhere. I can’t find it.
(it does boot up most of the time)

Thanks,
Kirk

it get's written on bootup to the serial port..

Regards,

I’m back and up and running with my new serial debug cable.
Maybe you can help me understand this.

I have 2 BBB’s one Original BBB and an Arrow industrial temperature BBB. Both were flashed from the same microSD card image.

Original BBB has new u-boot on it and will boot successfully. (see below Boot Log Original new u-boot.txt)

Then I connected to the new Arrow BBB before loading the new u-boot. It boots OK. (see Boot Log Arrow BBB old u-boot.txt)

Then I loaded the same new u-boot on the Arrow BBB and now it will not complete the boot. (see Boot Log Arrow BBB new u-boot.txt)
The | character at the end of this boot log file was a rotating line pattern that continued forever like it is waiting for something. All the BBB blue LED’s are on.

I really appreciate you taking the time to look at this,

Kirk

Arrow BBB's support is only in v4.1.x+, since it uses an ADI framer vs the
NXP one on the BBB, "I" didn't care enough to backport the ADI driver to
3.8.13... Thus you get ^ message..

You can force:

dtb=am335x-boneblack.dtb

in /boot/uEnv.txt just make sure to disable hdmi...
capemgr.disable_partno=BB-BONELT-HDMI,BB-BONELT-HDMIN

Regards,

That solved the problem! Thanks very much for your help with this.
I’m going to cycle on/off all night to make sure there are no more hang’s at boot up due to phantom serial port characters.

Have you (or anyone else) seen any documentation on differences in the Arrow board?

Kirk